Curve modifier

Im having some problems with the curve modifier that I don’t remember having before.
In my attatched images, imagine the shape as being the head and truck of a badly deformed elephant. :slight_smile:
I have assigned two vgroups to the mesh, the trunk and the head.
I then added a curve, centerpoint aligned exactly with the mesh.
When I add the curve modifier, it twists my assigned group 90 degrees. Is there a way to assign a curve modifier without this happening?

Attachments



Ctrl-A on both before adding the Modifier. If that doesn’t work then you have the Z-Axis blues:

http://membres.lycos.fr/bobois/Tuts/Extrusion_par_bev_ob/Alignement_des_axes/Alignement_des_axes_en.html

%<

Hi,
It looks like you need to change the curve application direction, which is taken from the target object’s track direction. With the target object (i.e. the deformed elephant head) selected, look for the button group including “TrackX” in Object buttons (F7), Anim Settings panel, and try one of the other values (it defaults to Y).

This .blend does what I think you’re trying to achieve.

OK Thanks artificer that was it. I have never seen that information before and never used those buttons. Thanks alot

Fligh Thanks for this link. I have had that problem more than a few times in the past. Bookmarked. I wish I had known about that a long time ago.