Curve path not editable in edit mode

Hello folks, first time posting. :slight_smile:
I have an issue with Blender that I have no idea how to solve.

It seems I pressed some button or activated something and I cannot edit any curves in my Blend file.

I made a rope with curve path and previously it worked like a dream, I could make any rope I want, by selecting the path and moving points in the curve the rope is filled in seamlessly. Now when I go to edit mode on the curve path , the path is in edit mode, I see the points, but I cannot select any of the points in the curve. I click on them and nothing happens. They don’t get highlighted or selected.

This is probably a setting because when I reset blender to defaults everything works, I can edit any curve. But not in my save file.

I’m not sure what I effed up. But it seems consistent, I cannot edit any curve, bezier, parth anything… I don’t know why. I’ve checked selection settings, curve settings, context menus, but no idea… It’s probably some obvious thing…

If anyone have some idea what is this, please let me know.

Thank you.


  • If I select my rope and path, copy, reset blender and paste them to a new scene, I can edit the points in a fresh scene, this tells me the issue is saved in my blender file where I have the model
  • if I edit the path, and from menu, select Select Random, it selects a random points and I can move it around, it shows as selected, and manipulate the curve as expected, but as soon as I click away and the point is deselected, I cannot select it or any other points again. I click on the point and it is not getting selected… This tells me this might be some selection issue?


With so many variables involved (i.e., all the possible settings available in a .blend file), it is hard to diagnose from the information given (unless someone happens to know exactly what the problem is). It is also a possibility that there is a bug in the file (some corruption, perhaps, not necessarily a bug in blender itself). This can happen as scenes get more complex, and you inadvertently do something. Uploading a file with only the offending curve would be helpful.

That said, you seem to have found a solution (but did not necessarily find the cause) by copying to a new file. With so many objects in the scene, perhaps try opening a new file, and Append the scene from the original file. If this eliminates the selection problem, continue working with the new file.

no I have not found the solution yet to this, but the workaround where I copy the parts to a new file and work there seems to work. Indeed my original file has rather many objects in it so maybe a full copy to another file will be the long term solution.

I don’t think further investigation is needed, I just thought it is an obvious setting or that I pressed something that can be reversed, if not, I just copy the models to a new file.

Thank you!