Cutting a hole in this mesh (without getting lots of triangles)


I’m stuck with a problem that always gets me stuck while modelin :S

I need to cut two small holes in to the bottom plane of this mesh:

I realize that in order to cut nice round holes, I need more geometry (at least 8 vertices) around where the hole should be…

So first I tried to make loop cuts around the whole object, but that makes the big round hole distort and loose it’s roundness.

Then I tried to only subdivide the four big faces on the bottom plane, but that resulted in triangles surrounding the area.

I’m lost and I’m asking for your advice. How would you model the two holes into this shape?


I also tried to separate the four faces on the bottom part in order to avoid the triangles (on the outside faces) when subdividing them. This approach was ok otherwise but rendering shows this strange behaviour on the corners of the separated area. I tried to recalculate and flip the normals and I also tried to “set solid” for the shading of the area, but these artifacts remain :confused:

Here is a picture of the artifacts:

post your .blend file and you’ll get some feedback and maybe show some wireframes from a couple angles.

at first glance it appears you have z fighting, or in other words, you have overlapping faces. have you tried removing doubles?

Once you have gotten rid of all the non-manifold verts, removed doubles and have your normals pointing in the right direction, then you might consider trying to use the boolean modifiers.

But you probably don’t need booleans once you figure out your mesh problem.

Thanks for helping!

Here’s the blend file with the bottom part separated from the rest of the model. I know that the render issues happen because of z-index fighting between the two objects, but I have no idea how to fix this issue or how to cut the holes using some other technique.


socket example.blend (727 KB)

hey blockrocker, i made a tutorial about this, its uploading to youtube. ill post a link when its done. (i dont know why it takes so long?)

but i actually figured it out. no triangles, very clean geometry, and it has options.

whats the link to the tut?

Here’s my go at one of the holes it lines up with the subdivision of the main socket


socket_Append.blend (126 KB)

Here’s the link to my tutorial about this:


That’s pretty much what Blenderlogic do in his tutorial; only thing I would do different is to Crease edges instead of inserting those loopcuts moved to the extreme; this would spare some polygons.

fun exercise! :slight_smile:

my solution for the central part of the soket:

the second is the best solution, I think…

Ciao!! :slight_smile:

and the .blend!

socket_2.blend (677 KB)


Thanks for helping out guys, I will test what you suggested!


Blenderlogic, great tutorial! By watching it I realized that the answer to my problem was as simple as applying the subsurf modifier! This way I got the geometry I needed for the holes. Thanks for helping out to everyone!

wow i cant believe i didnt know about the crease thing! i just researched it, its pretty awesome! thanks for the suggestion, it helped.

Another option with quads
Because the area in the centre is flat you could also get away with subsurf and triangles if you so wish.


socket example (1).blend (643 KB)