Cycle Rendering - Odd Firefly effect?

That’s the best way that I feel I can describe this. I am just now trying out Cycles after watching a tutorial made by someone named Andrew Price, and thanks to his video I wasn’t ‘as’ afraid of using cycles as was before (and understand it better) But there is one thing that I can’t seem to fix:

I’m rendering a turret, in the rendered preview, everything looks like it should. But once I hit ‘render’, something odd happens, the top left of the render is all… err… pixalated? Kind of like I’ve got a bunch of multi-colored fireflies all over the place. I’ve tried changing the sampling rate but anything above .01 seems to make the render rather dark (it does get rid of the firefly like effect, but seems to make the render very dark and difficult to see the model :frowning: )

Anyone know what is going on? Attached an image to help.

Attachments


I think you’re changing the clamp value, not the number of samples. If you’re going to use clamp, you should set it to something above 1, but you need to increase your number of samples. It’s probably at something like 10 right now and needs to be in the hundreds. Try 100 or 200 to start with.

Actually I have hte samples set to 400 (will be upping that to six hundred later to see if it makes any difference) and right now the clamp is set to .16, this seems to have fixed ‘some’ of the fireflies that appear on it but I still notice some discoloration which continues to ruin the rendered scene =(

I can’t tell what sort of materials you’re trying to use there, but you might also try turning off caustics. Noise in cycles can also be helped by improving your lighting setup. And again, I wouldn’t set clamp values that low. Try setting it at 1. Like actual 1, not 0.1. Setting it much below 1 will seriously darken and discolor your render.

I would be very interested to see the solution for this problem!

I have been fooling around with lights and such in a very simple scene myself but I always get the same disgusting discoloration!

City.blend (2 MB)

Uploaded the blend file of the scene! (I tried 100,200,500,1000,2000 samples, it never really goes away)

Edit:

Also, it takes like 20 times longer to render but the only things I added since were the main box and the textures to it.

If related, my system consists of a GTX680 and a i5 3750k@4GHz

Best Regards

//Morgan

Downloaded your file Morgan, changed the clamp value a bit and that seems to fix the speckles a little bit. You’ll have to experiment with it a bit, with my own model, I learned I had to have the clamp value higher than I needed it to be for another project I’m working on. So you’ll have to experiment to see what works for you =)

Also, preview sample number, raise it a bit. When I had it at 200, most of the speckles were gone.

Bartek Skorupa over on cgcookie.com has a tutorial about removing cycles noise using the Bilateral Blur node in the Compositor. You should be able to access it without being a “member”: http://cgcookie.com/blender/2013/02/18/blender-bilateral-blur-compositing-node/

It is very hard scene for path tracers, many picture parts cannot be lit by direct light, so you need bidirectional integrator or photon map to render it faster.