Cycles/AMD Catalyst 12.xx Tests

I have been experimenting with the BMW test image by Mike Pan and here are my results.

My system:
OS - Windows 64 bit Pro
CPU - AMD Phenom II x6 1055T
GPU - ATI Radeon 5830 HD
CATALYST - 12.4 beta
RAM - 8gb
BLENDER - 2.62.3 r45555 (alb3530 GraphicAll.org)

The first time after installing the 12.4 catalyst took 4 minutes to compile kernels - a 4 minute pause before rendering - and then a render time of 1:16.13 with the following result:


I tried several different images, all with the same color issue in the render so I decided to try some things.

This is a render with the background image removed (under the world tab) with a render time of 1:10.76 :


If you remove the image texture for the windows they show up but with a lot of noise for 200 passes. I found that with any image I tested I had to remove the image texture for it to work and just use color.

I also found that as long as you worked on the same image the render was fast but if you changed to a new image it would always have a 4 minute pause after the BVH build before the render starts. Is this a compiling pause or is it another issue?

When I try to render this scene the console says OpenCL kernel compiled in XXX seconds (big differences, between 500s and 800s) but after that nothing happens anymore. I waited about 10 minutes.

But the render time is quite nice. My 6850 is a bit slower so it would take about 1.30. With my CPU it renders almost 10 minutes :smiley:

Fishlike - Do you have the catalyst 12.4 beta ? The same thing would happen to me when I was using the catalyst 12.3

i’ve just been experimenting with those beta drivers too, had some interesting things happening.

Specs:
OS - Win 64bit Pro (Ultimate? no idea, shouldn’t matter…)
CPU: AMD Phenom II x6 1110T
GPU - AMD Radeon HD6950
CATALYST - 12.4 beta
RAM - 6gb
BLENDER - 2.62.4 r45727 (alb3530 GraphicAll.org)

First tried the standard Cube, after building the kernel (444.16s) it just did nothing for few minutes, after that was insanely fast (1000 samples in 17sek).


Afterwards tried the BMW benchmark scene. The image looks a bit different than lking73’s result though, did you change anything besides the background in the scene? i just removed the background node.


Rendertimes:
CPU: 05:12
GPU: 01:16

Miraculously the ‘several minute loading time’, which i always had when i tried rendering the default cube scene, then just was gone! restarted blender, and now always starts right after bvh build. After downloading the bmw .blend file again, the loading time was back, but the default blend still worked right away, even when i replaced the cube with a subsurfed monkey. Why does it load so long on some cases but not on others? Other than the Strange Colors ‘bug’ and the loading time thing, it seems we’re finaly getting closer to Cycles on AMD graphics cards! yay!

I had same problem as Gexwing. 1:12 for gpu though 6950 2gig by HIS that is factory overclocked.

thats awsome, when you say rendertimes do u mean viewport rendering or actual f12 image/nimation button

psS sign up to my facebook cause

gexwing - The only setting I changed was the removal of the background node under the world tab.

I also did a render of the default cube using the sun lamp on the default setting. The render time was 00:03.11 at 200 passes.


When I tried to change the color nodes from diffuse to say glass or glossy the 4 minute pause came back before the render would start. I have found the more complex the node set-up the pause is always there but the more simple node set-ups it is not.

npm1 - My times reflect the F12 render. I have found that sometimes the view port render shows the color issue but the F12 render doesn’t show it.

I think that pasues because of jit- like hard oprimisation, when AMD driver hit new branch it start to optimize program again.

Another default cube test with the following specs:
Computer : OS - Windows 7 64bit pro
Processor - AMD Phenom II x6 1055T
RAM - 8gb
Graphics Card - ATI Radeon HD 5830 Catalyst 12.4
Blender - 2.63 r46078

Scene Settings : Default Cube with plane
Sun Lamp Strength 1 size .05
No Background Nodes in World Tab

GPU Render Time : 00:01.39 @ 50 passes


The size setting for the sun lamp needs to be smaller than the default setting of 1 to cast shadows better.

Using the sun lamp gives better results than using a plane for lighting. Using a plane I had to increase the strength to large amounts to get results (100 to 1000) but with the sun lamp the most I have had the strength was 5 .

Here is the BMW scene with a few modifications
GPU - 01:01.21 @ 200 passes


Obviously the glass shader still doesn’t work, but overall I think it looks good.

The modifications to the scene are as follows:
Removed the background node from world setting and the tires
Removed plane for lighting and used sun lamps with emission of 3
removed the ground and replaced with a plane