Cycles, Background movie and alpha matta - Newbie question

Hello
I am struggling to render a camera tracked scene using a video background and cycles. That said, blender render does not work either. The goal is to have a composited scene. For the moment, I can only see the background. I can manage to see the foreground if I mix the two but I am unable to get an alpha of the scene, therefore I can a ghost of 3D in the scene. The Alpha channel is white for the scene, therefore I am clearly not creating one. I have no problem viewing the scene in the 3D View.
I attach this simple scene.
Any ideas are very welcome
Thank you

I don’t know if this is right but it worked for me.
Initially, my render setting were set to jpeg. JPEG has no alpha, so I presume it was already going to be difficult.
In the Render Settings / Film tab, I clicked Transparent.
I set my render output file to Open EXR with RGBA and all of a sudden I could see the alpha checkboard appeared.
It does not seem to be very logical, but …