Cycles baking testbuild gives black image (no displacement used)

I’ve been using Blender for a few months to make the models for a game (actual game engine is Unity Free). I’m new to Blender and 3D modelling in general, so please be patient with me if I’m doing something stupid or I use the wrong terminology.

Anyways, I got the Blender 2.71 testbuild 2 and I’ve been using it for baking in my Cycles materials for my game. It’s been working pretty good, but for one of my models it isn’t working. I go and press “Bake” with bake type set to “Combined” and I wait there for an hour or so and instead of baking the model in full color (like it normally does), the UV’s are all black (see “combined bake.png”). Am I doing something wrong here? (I’ve uploaded my .blend file if anyone wants to see it.)

Also, this is how I normally do cycles baking (this has worked for my other models): First, I go into edit mode and do a Smart UV project. Then I go into one of my materials and open up the node editor. I add a Texture Coordinate node. Then I add an Image Texture node and set the file to whichever file I want to bake to. I then take the UV from the Texture Coordinate and put it into the Vector node in the Image Texture. I repeat the process for each of the object’s materials. Then I go to Render>Bake and press Bake with the type set to combined bake. This normally does work for my other models. The only thing different with this one is that there is a crystal thing hovering over the object I’m baking. The crystal has a strong emission shader. Is there anything wrong here?

Please help, this is getting really annoying. :mad:

Uploaded files:
“combined bake.png” - the result I get when trying to bake
“rendered.png” - the rendered result
“full file.blend” - the blend file of my model if you need to see it. I want to bake the gray base of my model. I have already UV-unwrapped it.

(Note: I tried this on the Blender 2.71 RC1 from that just came out - still no luck :()


full file.blend (675 KB)

Anyone have an idea?

Nevermind. I feel like an idiot now. All you have to do is recalculate the normals.

funny, I did the same thing yesterday. I rebaked normals half a dozen times and finally realized they were inside out.

Normally I have ‘back-face culling’ activated and this makes it very easy to see when something like this is wrong.

For the past few days I’ve been trying to work without it, I’m definitely going back to always keeping it activated!