Cycles: Caustics for 2.70

I maybe missing it but I’ve looked around.

Can someone tell me how to get proper caustics for version 2.70

Is what I have now and it’s poor.


I like how people on this forum keep their secrets but don’t assist others. Fantastic. You must feel so proud of yourselves.

I’d like, specifically, how to get realistic colored “liquid” in the container to show up.

Seriously… you made a post, which first had to be approved by a mod, and then waited way less than a day to get a response before assuming that people are just holding out on you.

Did you even do a cursory glance at the render settings? There’s a setting specifically for caustics. If you don’t have them turned off and you’re still not seeing anything, then it’s a problem with your scene/lighting. Either way, even if you get them working, be prepared to wait a looooong time for a clear render. Unidirectional path tracers are not designed to render caustics. If you really need caustics, consider checking out a bidirectional or photon mapping renderer.

On a saturday too…

OP - you may wish to reconsider the tone of your posts - posts like your second one accusing people of “keeping secrets” was extremely childish - and will not endear you to the people on this board. You may well find all of your posts going unanswered if you throw toys out of your pram every time a question isnt answered within your strict timeframe.

People have these things called ‘lives’ and don’t spend every waking moment poised at their keyboards waiting to answer questions. I have posted questions on these boards before - then through a combination of tinkering and Googling - have actually found a solution myself before anybody had a chance to reply…that’s just the way it works.

Back on topic however:

The most obvious thing I can think of is that OP has the “No Caustics” option ticked in the “Light Paths” section of the Render panel. By default - Cycles has caustics disabled. Either select it - or switch the light paths section from “Limited Global Illumination” to “Full Global Illumination”

If the caustics are noisy - try upping the “filter glossy” setting to between 0.1 and 0.5 - and perhaps up the “Clamp Indirect” value too - say between 2 and 4.

not certain you can get color in the liquid itself

as I remember some good caustic in cl takes sample well over 1000 or 2000
cycles is not really good at caustic anyway!

but it is possible to boost the caustic outside the glass

but here is some notes I got over time

In2.64, you will be able to use the ‘filter glossy’ option to blur outthe outlying samples and keep the large, central part of the causticintact (looking at your image there). You will also be able to use anew non-progressive integrator where you can jack up the number ofindirect diffuse samples (which according to my tests covers causticsamples).
Also,set the min bounces value to the same amount of max bounces (as ithas a major effect on how caustics will come out.

Caustics may be a weak point in Cycles right now (that is until Storm_stcompletes the bi-dir integrator), but it’s better than what we usedto have in BI which is none at all

In2.66 Spot lamps do work with caustics now, for anyone interested. You just have to enable Multiple Importance Sampling in thelamp properties. In some preliminary tests built in lamps areas fast/faster than mesh lights now. To get more caustic effect you can add a lightpath node like this to theobject light source as emission

so have fun with cycles
but to get really great caustics try it with yafaray or luxrender !

happy cl