Cycles changes the form of the mesh

In the other viewports, my ground mesh looks smooth and natural, but in cycles rendered view, it gets sharp edges and geometric shapes. And it moves from the vertex and edges framework, so there is a gap between the particle system spread bushes and the ground, the bushes seem to float in the air.

What am I missing? There’s a bit complicated to edit the shape of something that changes when I turn to rendered view… Any ideas?

Can you provide screenshots or examples? If possible a refference for what you want to acheive?

Bushes flying above ground in cycles rendered:

And bushes not flying in dev view:
It was a bit hard to produce pictures of the sharp geometric problem, it’s not as bad as it was before, also the other views look a bit more angled than I remember them too. “Before” is two days ago when I wrote the question, after that I tried a lot of solutions, added subdivisions and ended up with a Smooth modifier, which is applied now. But please take my word for it when I say it looked worse before, the dev view and solid view, and eevee rendered, looked smooth and nice, but the cycles rendered was angled and sharp. It’s like I would like to tell it to use shade smooth, only, it’s already shading smooth.

Oh, and also, I’m using a displacement, and I thought that was the problem. But I tried without the displacement too, and it didn’t get any better.

Oh, and now when I disconnect the displacement again to make sure, the ground rises to meet the bushes… (Feeling a bit stupid, ok.) Well, ok, anyway, why does the displacement create this inconvenient result? And how can I use the displacement without the particle system hanging in the air? My guess it has something to do with the Midlevel and Scale, I’m not really sure what these settings do.

Displacement in cycles does exactly what its name suggests, it displaces geometry. It is usually used in conjunction with high levels of subdivision to get smooth results. Take a look at some displacement tutorials.
What are your node settings?
If you want to fake surface detail without displacing the geometry you should use a bump node or a normal map.
Edit Here are some examples:


This is a heavily subdivided plane using displacement. This is the usual use case for displacement.


This is the same plane and displacement with only 10 subdivisions (note the sharp displaced edges)


The same plane using the same noise texture as bump (not displacement)

One thing i can say is that cycles is more acurate and so when there are sharp edges and shro shadowa it can look pointy. I would suggest some more subdivision. If you want i can make a similar example or if you upload your blend file i will clone the scene to see what i can do quickklu and you can compare the two

Midlevel will rise and lower the displaced mesh, strength is the amount of displacement.
If you want your particle system to react to the displacement you have to use a displacement modifier on your object instead of displacement nodes in your texture, like this:


in this example the plane was already subdivided ten times in edit mode before the subdivision modifier so there is a lot of geometry.

Ah, of course, yes, when you mention it, I kind of remember that you need a ton of vert’s to make it look good. I forgot since it looked kind of how I wanted it without the extra ton, (I just wanted some small structure on the snowy ground) and I didn’t know that it could also move the overall hills and dales around.

This is with the displacement:

And with the displacement disconnected:

I’m generally using a noise texture to get the structure, then I also added a mix that would take the darker parts of the ground texture into consideration.

Not entirely sure I packed the blend file correctly, it’s my first try, but here it is. Or not. It was to big to upload. :confused:

I tried out some more subdivision, but it didn’t give me the effect I was after.


Now it has a lot of “foot size” holes and bumps, but I’d like soft smooth hills with just some tiny texture on the snow, like in my earlier example.

For soft smooth hills simply subdivide your basic mesh (and rightclick shade smooth in object mode).
If you are after

Forget displacement and use a bump or normal map with lowish strength.

1 Like