Cycles CPU/GPU SSS Benchmark


(nudelZ) #1

:yes:

important!

don’t change the settings except “compute device” and “tile order/size”!
don’t use blender < 2.71.6!
provide all necessary informations!


tips:
close all programs if possible
change the nice/priority value in the task manager

the result should look like this


grab a build here https://builder.blender.org/download/

  1. Final render resolution is 759 x 864 (don’t change it - numbers are just to help you to play with the tile size)
  2. Change tile size and/or order
  3. F12
  4. Post results (copy below)

Example:

OS: Ubuntu 14.04 64Bit
Blender: 2.71.6
Build: Buildbot (Own, Buildbot, official, …)
Revision: f823ea1

CPU: i7-4930K 4.5GHZ
Tiles: 16x16
Optimization: -
Time: 08:29.85

GPU: 630GT 1GB - not supported
Tiles: -
Optimization: -
Time: -

File & Results

don’t know if it works with 1.5/2gb vram - if not i’ll lower the quality and change some settings!

please test! :yes:

I can add a link in the “Nick” column if you like - just post the link under your results or pm me :slight_smile:


(English is not my native language) #2

Hello.
Could you upload the file to another server? It is the second time I try to download the file. When the download is finishing then it stops, and it seems not to support resume.


(cekuhnen) #3

1920 * 1080 at 80%

iMac 2008 Core 2 Duo 3.06 GHz
01:09:20.14

MacPro 2008 2 x 2.8 GHz Xeon
18:47.03

NVIDIA GTX 570 CUDA 6.0
not working - bugged renders transparent image in seconds


(English is not my native language) #4

Thanks for upload the file to Dropbox…

OS: Kubuntu 14.04 64Bit
Blender: 2.71.6
Build: Buildbot
Revision: 526ae63

CPU: intel i7-3770 @3.7GHz
Tiles: 16x16
Time: 15:43.55


(aermartin) #5

Do’h I had an old SSS shader file by NudelZ laying around in the same download folder so I opened that one,

OS: Win8
Buildbot

CPU: Intel i7-3820 @3.6Ghz
Tiles: 16x16
Time: 18:31.58

GPU: 2x GTX580 3Gb
Tiles 256x256
Time: ?

Was doing great time but I got this error. http://nvidia.custhelp.com/app/answers/detail/a_id/3007
I think I need to fix that registry point or either wait until I can upgrade the gfx cards.

I got a total pink screen also the try before, but tweaking how my fans performs on the gfx cards prohibited that. needless to say Cycles and this SSS skin scene pushes cycles to it’s limits on my hardware :stuck_out_tongue:

the GPUs had an constant load of 99-100 % sometimes dipped when starting a new tile.

GPU1 had 2.7Gb of vram used out of 3.0Gb, and GPU2 had 1.9Gb so it’s pushing the limit there also, below 3Gb I think is unpossible to render this scene with.

I might give the GPU a go later after tweaking. Or stick to simpler scenes until I upgrade.


(Thies Schulz-Holland) #6

OS: Win 7 Ultimate SP1 x64
Blender: 2.71.6
Build: Buildbot
Revision: 526ae63

CPU: AMD FX-8350 @ 4.6 GHz
Tiles: 16x16
Optimization: -
Time: 18:51.91

GPU: GTX 680 4GB
Tiles: 256x256
Optimization: -
Time: 10:41.43

(for the original “head” file)


(nudelZ) #7

@ cekuhnen please provide more informations otherwise I can’t add you…

os?
blender build?
tiles?
vram?
@ aermatin are you sure you opened the right file? (sounds like an old shader file from me o_o)

“cycles_sss_bench_pre272.blend” ~150mb ?

https://docs.google.com/uc?id=0B1mc80hFkBqcU0xoanptX1hxRjg&export=download


(ARK) #8

My results
OS: Windows 7 Pro 64bit
Blender: 2.71
Defult file res

CPU - AMD Athlon II 640 x4 (OC to 3.5)
tile: 16x16
Time - 42:21.14
GPU - Asus 770gtx 2gb
Tile: 256x256
Time: 1:04.20

Some reason the GPU render the light on the face is darker??


(nudelZ) #9

ARK please don’t use 2.71 for the benchmark :slight_smile: sss for gpu is not supported with this version!

https://builder.blender.org/download/


(ARK) #10

Sorry NudelZ. Downloaded it and ran it. All looked good but had same problem as Aermartin. This error happens alot with me now for some reason and not yet found an answer.


(nudelZ) #11

ok… i’ve no clue about gpu rendering - sorry - maybe someone else…

if you run the cpu bench again (buildbot build) then I can add your results :slight_smile:


(Thies Schulz-Holland) #12

It’s strange that so many 2 and 3 GB GTX cards can’t render the scene: The memory peak stays below 500 MB…? Maybe it’s a driver issue? My aging GTX 680 4GB had no problems on nVidia driver version 340.52.


(Spozzfreund) #13

Mr. nudelZ Sir, take this! :smiley:

OS: Win 7 - 64bit
Blender: 2.71.6
Build: Buildbot
Revision: 526ae63

CPU: AMD 1090T 6x 3.2GHz
Tiles: 16x16
Optimization: - O_o
Time: 25:37.55

GPU: 650Ti 2GB EVGA - works! :smiley: (GeForce 340.52 Driver)
Tiles: - 95x96
Optimization: - o_O
Time: - 23:12.03
VRAM usage: - 1133MB


(stevew2511) #14

Are you serious? 1min and 4 secs on the GPU? Here’s mine:

OS: Windows 7 Home 64Bit
Blender: 2.71.6
Build: Buildbot
Revision: 526ae63

CPU: Intel i7 930 (2.8 Ghz)

GPU: Inno3d GTX780 6GB
Tiles: - 768 x 432
Optimization: -
Time: - 5:53.09

For tile size; I found that if you take the final image resolution and divide by two for both the x and y I get faster results.


(nudelZ) #15

stevew2511 he used the wrong build :slight_smile:

please - mention your cpu model (not the bench results - just the model) then i’ll add your results :slight_smile:

btw: why tile x “768”? and it is only 1 gpu?


(Lockal) #16

My score:

OS: Ubuntu 14.10 64Bit
Blender: 2.71.6
Build: Buildbot
Revision: 526ae63

CPU: i7-4771 3.50GHz
Tiles: 16x16
Optimization: -
Time: 14.28:14
Memory: 472M, Peak 472M

GPU: GeForce GTX 690 2GB (both cores)
Tiles: 256x256
Optimization: -
Time: 05:36.19
Memory: 944M, Peak 948M


(riveter) #17

My Results:

OS: Windows 7 64Bit
Blender: 2.71.6
Build: Buildbot
Revision: cb7d430

CPU: AMD 1090T

GPU: GTX 660 2GB
Tiles: 64x64
Time: 16:59.78

Rendered on GPU


(tungee) #18

OS: Windows 8.1 64Bit
Blender: 2.71.6
Build: Buildbot
Revision: cb7d430

GPU: 2x GTX 780 Ti
256 Tile
3:03.32 :yes:

CPU: i7-4770 3.50GHz
Tiles: 16x16
Time: 14.23:22:no:


(nudelZ) #19

tungee - tile size and vram please :wink: and stock cpu speed?

stewev2511 - windows 7? also stock cpu speed?


(Elonius) #20

OS: Windows 7 64bit
Blender: 2.71.6
Build: Buildbot
Revision: 526ae63
CPU: 3770k

GPU: Titan Black SC + GTX 680 2 GB
Tiles: 256 x 288, Static BVH
Time: 03:32.70
Mem: 949.37M
Peak: 949.46M