Cycles Crash when rendering

Hey everyone,

I have a scene where I use multiple photos with an emission shader to texture one model.
All my photos work perfectly, except for one. As soon as I want to use this image while rendering in Cycles Blender crashes immediately.
Everything works perfectly in Eevee, but unfortionately I want to bake everything into one texture an I can´t do that in Eevee…
Do you have any idea what I could be doing wrong? The node setup is the same for all the images so I don´t think that is the problem.

If this isn´t enough information don´t hesitate to ask!

Try resaving the image. In all my years with Cycles, I have had one .jpg that was “corrupt”.
If not, try disabling some of the others and see if that helps, like if it was a memory issue.

Resaving the image… what do you mean?

Open the photo in whatever software you use and save it again. Maybe try another format or change its size. I don’t know where it originates from in your case, but for me it was one of several photos we got from customer to use. No problem opening the “corrupt” file anywhere, but in Blender it would just crash. After resaving to a new file, Blender was able to use it.

I just tried with the official 2.82 version and the problem is still there. I don’t think I ever reported it because it was a one of a kind - maybe I should. I can see the image in the file browser and image viewer and it works with Eevee. Switch to Cycles, and it crashes immediately either with viewport rendering or when starting a render.

Thank you very much that solved it!

If the image in question is not confidential customer information, consider creating a bug report on it. You could link back to this thread and the similar thread I created earlier today. I don’t know what causes it, but a developer should have better means to see what is going on.