Cycles Denoising "Hot Spots" problem in 2.79

How do I get rid of these splotches in my renders (see below). Seems to pop up on the brightest specular highlights.

I’ve included my render settings and the denoising settings. I don’t think it’s my material setup, since it seems to occur on different materials. Increasing the number of samples doesn’t help (isn’t lower samples the idea with denoising?). Raising the denoising to a higher radius makes it worse.

Is this just something we’ll have to get used to with the denoising feature or (more likely) am I doing something wrong?

Render settings:

Denoising settings:

Hi. Clamp indirect and direct with safe values. This is probably coming from direct, but clamping indirect can also help you get less fireflies and help denoiser in general.

This is a known issue as previously acknowledged by Lukas on the developer site (and I think resolving it is not exactly a trivial fix either).

The only solution at this point is to render with more samples (how much more depends on the total variance in the color values).

Are you sure that samples is the issue here? I’ve encountered the same thing, and it seems to be in specific circumstances (high reflectivity and real lights as I remember).

Certainly I use denoising by default and it is only specific scenes it occurs. Where it has upping the samples (even by a power of 10) doesn’t help.

Yes – I was thinking maybe upping the samples might help but it didn’t. It’s gotta be a denoising setting, but I haven’t found the sweet spot yet.

Hello again.
These kind of artifacts are known issues and pending to be solved. In some cases they are not solved by increasing samples. As I said, a workaround can be set up clamp values.
In this case artifacts disappear to clamp indirect:

In this other case (more similar to yours) black artifacts disappear to clamp direct:

You can test with Clamp direct=15 and clamp indirect=10 for example. If artifacts still do not disappear, continue testing with smaller values.

But here I do not have a scene to test. If you do not want to share the model, you could just share a blend file with an sphere/monkey using the material and the same configuration if artifacts can be reproduced that way.

Also that artifacts appear sometimes depends on the intensity and size of the lamps.

In many cases, from my experience, the artifacts can be resolved with increasing samples if you set the weighting values somewhere below the default of 0.5 (I use a value of 0.4 at max).

Sometimes it still takes a lot of samples to resolve them, but if you have a complex interior scene, then you need lots of samples anyway to not lose detail. This also seems to combat other potential issues such as black pixels in narrow highlights and the over-blurring of some reflections.

It’s true Ace, sometimes. But you see suzanne example in previous bug report. With 5000 samples black pixels still appear.
I think Clamp is the most suitable option in many cases. Keep in mind that artifacts disappear even using high values, so dynamic range is not cut much. In Blender from Master, Clamp inidrect is now set to 10 by default for new scenes.

If I could remember which scene of mine it was on, I’d happily share. Just tested the one I thought it was, but no. If I find it, I’ll post it.

I think that Russian Roulette method in master (not present in 2.79 release) is helping in some way to make denoising artifacts a little less visible. So you should better use 2.79 official release to find that scene (in case you were using Blender from buildbot/master).

Clarification: I requested scene more than anything because out of curiosity and to do tests to better help in this thread, I am not a developer. Problematic scenes should be shared in bug reports if the intention was to show it to developers.

I’ll share a sample of my scene without the model as you suggested, but it will be Monday before I can get to it. I did notice that using low values (below 1.0) for Clamp Direct made the scene really dark and low contrast, so I’ll try it with high values and see what happens. The Clamp Indirect settings I used didn’t seem to help clear up the spotting.

BTW – you can see a version of the scene on my DeviantArt page if you’re interested.

Clamp affects lighting/dynamic range, you should not use values below 1. The reality is that Clamp values are not well documented to be better understood. You start by testing for large values. You will usually use a larger value for direct light.

Any news on this? I’m really curious about if there really is no feasible workaround for this.

Considering that clamping doesn’t help in this case and considering that Lukas is nowhere to be found now, The current issues may or may not be fixed at any time in the near future (unless Brecht or another developer starts to tinker with the code).

Until then, you’ll just have to use weighting values below 0.5 and render with a lot more samples.

Just to note, I’m not going to say one way or the other if Lukas Stockner left Blender development, but his last post on BA expressed dismay that it might be a long while before his new work is in a usable release (which is 2.8, which really does have a ways to go yet). Again, I don’t know, he might just be taking a well deserved break from the nonstop work it took to get denoising into master.

I did a few tests with the Direct Clamping as YAFU suggested and it did reduce the black spots significantly. Some detail is lost, but it’s not very noticeable – mainly in the specular highlights (see image). Render times weren’t impacted much, but it did add a few seconds here and there. I did find it interesting that I didn’t notice a huge difference between clamping values of 12 and 1, but like I said, I lost some detail in the reflections.

Well, I would like to have a better documentation about Clamp, which is understandable by normal users.
In my understanding you should use as large a value as possible, as long as the artifacts do not appear. Anyway in the tooltip that appears in Blender mentions that Higher values will be scaled down… But, starting from what value does it refer as “Higher”?
Direct clamp=1 still greatly affects the result. You try it on BMW27.blend scene. Even this affects the rendering used for compositing in the headlights in that scene.
In the scene from the second bug report I mentioned above, even Direct Clamp=50 seems to be safe.
So, you experiment with what values you think you get the best results.
And you’ll also be a bit more generous with sample values (as Ace advised). In the image of the first message you notice the patches that appear when you are clearly using low render sample rates for denoising.

If your scene has any kind of subtle reflecting/refracting effects and you want to keep detail, you can’t use low sample rates anyway (otherwise that kind of detail will be blurred).

[QUOTE]‘Again, I don’t know, he might just be taking a well deserved break from the nonstop work it took to get denoising into master’

Ace, I can only hope that is the case since I was hoping something would show up on the nightly builds reflecting his efforts before 2.8. But, you mention another possibility whereas Denoising might become a stepchild of sorts.

Higher clamping rates do affect render times (in my experience); I was under the assumption that the denoising feature was put in to allow you to use lower sampling rates, thus reducing render times. I understand that it’s not made for final renders per se, but if I have to increase sample/clamping rates to get rid of the spots, I might as well just turn off denoising and use slightly higher samples, which would result in about the same render times but without the spots. Am I barking up the wrong tree?

Nope, I’ve just been working for Theory Studios for the last few months and was quite busy with university as well. Denoising development will go on, no worries. Also, I think you misunderstood my post, 2.8 is an extremely important release and taking a lot of time for it is extremely important and a good thing. I was just pointing out that you shouldn’t expect 2.8 in 2017.
Regarding the issue discussed here - yeah, it’s known, I’ll try to improve it once I find the time.