Cycles Development Updates

Ah, interesting. It was default the last time I tested and I believe it is meant to be default.
There is thread on devtalk where Brecht explains this.

Just to clarify things a bit. The latest 3.0 / 3.1 builds all render progressively. It might be a bit confusing to see this though:

image

The “Using Tiling” option just means that if your resolution is larger than a specified size in pixels, Cycles will split it in (huge) pieces and render each piece or tile separately to avoid your GPU running out of memory. The default of 2048px means that a full HD frame with 1920x1080px will be rendered in a single tile, but progressively.

1 Like

If I’m not mistaking today’s Cycles development update blog post hasn’t been posted here yet, so to make sure here’s the link:

4 Likes

I’m using Cycles-X for a personal test project (archiv exterior and interior).
One of the rooms I’ve is with a big frosted glass on one side and two door-windows on the opposite side.
The lighting I’ve choosen for the whole scene put light inside this room just as indirect lighting.
Well, I can’t clean this. I’m trying everything (except denoising i don’t like) but with no luck.
I’m using a GTX1070 (not super fast card nowadays) but with 5000 samples I can’t clean and still noisy.
I hope they’ll introduce some caching system or something new that face these scenarios.

said this, I have to make my compliments for the update, comparing with 2.9x Cycles it seems clearly a great step.
Go on devs and show us the next features!

oh ok i had no idea.
so whats a good workflow? I usually render 4K images. should i put it at default 2048, or should i put it higher 4096?

Depending on your GPU and the complexity of the scene you want to render you can even try disabling the tiling completely.
Just try rendering the same image a few times with different settings. I guess that even 2048px isn’t too small of a tile size to cause any negative effects on render time but your mileage may vary.

Are your lighting the room through the glass? So that the only light in the room is “caustics”?
Then noise is more than expected

Yes, actually yes.
This room borders with the living room where the sunlight enters…so actually the light is coming from the frosted glass is indirect light of the living room.
I know that it’s not the best scenario, probably I have to use some area lights to fake this incoming indirect light but I’d like to avoid this kind of setup.

You could make the frosted glass emissive - it makes surprisingly little difference to the look of the scene, but increases render times significantly.

I’ll try your suggestion. thank you

Yes, and on top of that example: you can also use a Lightpath node and bound the emission shader just to diffuse paths, so that everything else, included reflections, work just as a frosted glass.
Just make sure you’re emitting only in one direction :wink:

2 Likes

Thank you for your suggestion, it seems working and helping a bit.

Exactly. Tile rendering preserve from oom. Progressive, will be used for fast feedback on a “global”/“full frame” render.
With dimensions reduced if not enough memory.