Cycles does not show GPU, what is the problem?

I’m not getting a GPU or CUDA option in Cycles; could anyone explain what I need to do?

My technical setup is:

  • Fedora 19 64 bit, recently updated
  • GTX 760 video card
  • nvidia drivers from rpmfusion
  • CUDA not installed as it has not been released for Fedora 19 yet
  • various Blender builds, including the download from the website (also the Fedora repository version); all have the same issue

So I start Blender, set Cycles render, go to user preferences > system, and…

  • what I expect from the documentation is some sort of dropdown that enables me to select CPU or GPU (CUDA?)
  • what I get is a button saying ‘no hardware’ and a dropdown with just CPU.

So can anyone help me? What should I be doing? Is this the correct forum for this issue? Do I need to install CUDA?


  • I know there are other posts here about Cycles, but they do not answer my question, and I thought it best to keep my issues in a separate thread.
  • Nvidia’s CUDA has two install options. I cannot get CUDA installed properly with either of them. The RPM route only works for Fedora 18 (I am on 19) and if I delete the rpmfusion driver and install the CUDA driver my video does not work. The Run route stops with a compiler error; it does not work with the current gcc. First, I need to know if CUDA is essential for Blender GPU rendering.

Regards, Martin

Yes, Blender GPU rendering is 99.9999% CUDA at the moment… There is a OpenCL version which can be enabled… but there are still some problems with it.

Doublebishop: thanks for replying, and yes, I know that I need somehow to get CUDA working. But what exactly do I do? I’m a CUDA newbie, in other words (I have used earlier versions of Blender). I need some basic installation instructions.

More specifically, do I need to install CUDA?

Hi, if you meant Cuda Toolkit, it is not needed to use GPU with Cycles.
If you compile Blender for yourself you need Cuda Toolkit 5.0.

Which driver version is installed, is it the official Nvidia driver?
Use only official Blender version from

Cheers, mib.

mib2berlin: I have

  • official Blender from
  • nvidia driver from rpmfusion (see original post)

I do not want to build blender myself. I have done so in the past, but it is a lot of effort and I always find myself disabling FFMPEG or something to make it build.

But the question is still, why do I not have the GPU enabled? Do I need to install CUDA anything?


Do I need to install CUDA anything?

I meant which driver version, latest is 319.60, I use 319.29.
Find out with nvidia-settings in terminal.
You could try other Cuda render engine Octane for Linux:
Testfiles in download area.

Cheers, mib.

There are Blender builds that do not include the precompiled CUDA Kernel so you need to install CUDA Toolkit. But if you’ve downloaded the official binary or daily build (, they include precompiled CUDA Kernel and you do not need install CUDA toolkit.

Have you checked that the nvidia driver is loaded properly (xorg log)? Are you able to open nvidia-settings? What output obtained with the next commands?

lsmod | grep -i nvidia

glxinfo | grep -i render

For “glxinfo” maybe you need install an extra package (mesa-utils for Ubuntu)

As indicated mib2berlin, the driver version is important. Apparently your nvidia card is properly supported from version 319.23 (or 319.32)

OK, thanks for replying. So I have entered a few commands, and I get:

~/git/blend> lsmod | grep -i nvidia
nvidia               9365874  30 
drm                   278576  2 nvidia
i2c_core               34242  3 drm,i2c_i801,nvidia
[1]+  Exit 1                  xfwm4


~/git/blend> glxinfo | grep -i render
direct rendering: Yes
OpenGL renderer string: GeForce GTX 760/PCIe/SSE2
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, GL_NVX_nvenc_interop, 
    GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, GL_NVX_nvenc_interop, 
    GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 


~/git/blend> modinfo nvidia
filename:       /lib/modules/3.11.3-201.fc19.x86_64/extra/nvidia/nvidia.ko
alias:          char-major-195-*
version:        325.15
supported:      external
license:        NVIDIA

So it seems I am running version 325 of the nvidia driver.

I have the same problem. But I have Intel core i7. What should I do?

Hello! I had the same problem on Fedora 20 x86_64 with RpmFusion drivers.

The solution is:

su -
cd /usr/lib64/nvidia
ln -s

I hope that helps. :slight_smile: