Cycles doesn't render everything in a scene


I’m doing an architectural render and have roughed in the building envelope and structural elements. All is going well, except when I render the scene in Cycles. Everything by the walls and floor (all one object) render. They show up in Solid Mode and Rendered Mode with Cycles chosen, but don’t show in the final render.

Here’s a few screen shots:

I imagine it’s a fairly simple issue. I’ve tried flipping / recalculating normals with no luck.

If someone wants the blend file, I’ll attach it to another post…

Look in the outliner. You see all those camera icons. If the camera is greyed out ithe object will not appear in the render. You have 2 objects in that outliner whose render visibility is disabled. Click the camera icon on both. Nice looking model

Cube.002 and Cube.009 have switched off “renderability” - camera icons in Outliner. Is this what does not render?
Also, check surface normals in edit mode (N-tab, Face normals). I suspect walls and floor is flipped.

Duh. Been awhile since I’ve worked with rendering. :slight_smile:

Anyway, thanks!

looks creepy-btw