Cycles DOF inconsistency

Hi guys,

I’ve noticed a few oddities regarding setting up a Shallow DOF (Depth of Field) with Cycles. I was wondering if anyone else has had this issue and if they know of a fix?

Essentially the preview renders fine, where as the actual render into a new window doesn’t O_o

Additionally the scene is to scale, the mug for example is 8cm x 9.5cm

Here’s the shots to compare:




Is this a bug I wonder?

Edit: Sorry the last image should read “Full” Render (F12), not “Preview” as it says - sorry for the confusion.

I’ve been through the same problem and couldn’t figure out what was the cause. I could however go around it by importing all the objects into a new file. It worked then, but if someone knows why this happens I would appreciate too.

Bunch of default cubes behave properly here. 2.61.4 r43842

So, the wrong DOF only happens when rendering with F12? You Image is saying that it happens in Preview render, bit confusing.
A while ago (end December beginning January) there was a bug similar to yours using a model as a focus object but that got fixed. It was some scaling bug and got fixed quite fast but i think it was after the release of 2.61 so the fix is only in SVN so try a build from graphicall or the RC version of blender 2.62.

If it still doesn’t work, i like to know a bit more:
What do you use for focusing? An Empty, Manual or a Mug? (Try changing it)
Does it happen in both cpu and gpu?
Did you scale you scene after you created it? might be some kind of new scaling bug try to apply the scale with ctrl+a.

hope that helps

Hi guys,

Well I figured it was a bug and I was right (how could it not be I guess) - Anyhu, as suggested by OscarM, I downloaded a new SVN version from graphicall.org, and the new version worked fine in both Preview and Full Render (F12).

Sorry for the confusion on the second image, it should have read “Final Render” (F12).

Cheers, :wink: