Cycles emission material - render only light, not object?

Hi,

is there any way of making only the cast light of an emitting material in Cycles appear in the render? It happened to me today, that I found the perfect lighting with several planes, but one of them is visible in front of the lit object. I’d like to render only the light, as lamp objects do, but I like the directional qualities and easy adjustment of emitting planes very much.

There is visibility flag for that, select light, in object property panel -> Ray Visibility-> Camera

Perfect. Thanks a lot. :slight_smile: