Cycles Glossy Indirect Pass noisy on edges

I am rendering a scene:
http://fc01.deviantart.net/fs70/f/2013/103/3/e/test_render_by_mstuff-d61m6n3.png (File too large)

Though the glossy indirect pass has a lot of noise which I seem unable to remove:



Note the noisy edges on the sign and on the windows.
Bilateral blur is applied to the render pass, gives a painterly look.

Is this a known problem with cycles or am I doing something wrong?

All you really need to do is render out some more samples, many scenes might require 1000 or more to become noise-free (less if you’re just rendering to the point where you can smooth it out with bilateral blur).

Alright, I guess I’ll scrap the bilateral blur painterly look idea… I just think it made the render a bit more dynamic. Maybe I’ll find a workaround.
The render went through 512 samples.

Even with 1024 samples the noise is still present:



I might have to go 2000+ for it to be removed… :frowning:

It looks like the big issue here is fireflies, here are a few tips that might help.

-Make use of the ‘filter glossy’ option, this will smooth out the illumination falling on glossy and glass surfaces and will remove some noise at high-enough values.
-Use the ‘clamp’ option and set it at perhaps 20 or so, this can also help you manage fireflies.
-Use the ‘despeckle’ filter node inside the compositor, this node, unlike the one for bilateral blur, is specifically designed to remove fireflies, so you’d use the despeckle node first to de-firefly the scene and then the bilaterial blur to smooth the remaining noise.