Cycles GPU Render issue with AMD Radeon HD 6970M on Mac (OpenCL)

When I try to enable the GPU Cycles rendering in Blender (I’ve tried it with 2.64 Alpha and 2.62 – both had the same error), It tells me: “OpenCL build failed: errors in console”. This only happens when I try to use the Rendered viewport; if I try to render normally, it doesn’t report any errors, but still does not work. I’ve tried and failed to see what has been written to the console, because I can’t find it – I looked at the Python console and the info panel – though I don’t think this is a problem with Blender, I guess I just don’t know where to look. I have tried this multiple times with different builds of Blender (the two listed above) as well as different materials ranging from nothing but normal shadows to complex node trees. I am running Mac OSX 10.7.4 with an AMD Radeon HD 6970M. There is, obviously, no option to use CUDA. I’ve tried running Software Update, but it tells me there is nothing new to download, so I’m assuming that I have the most recent drivers. Everything else with Blender seems to work, including CPU rendering with Cycles. Does anyone know what’s causing this problem and how to fix it? Is it possible that I need to update my drivers some other way? (I’ve looked at the AMD website and there doesn’t seem to be any support for Mac – damn Software Update!) Could I need a different version of OpenCL?

I’m completely lost in the world of graphics cards and OpenCL, and any help is appreciated. Thanks in advance!

GPU rendering is only supported on Nvidia cards, unfortunately.

Meanwhile it runs on ATI too - at least i got a version running with the Experimental subset. basically giving you the features of a CUDA 1.2 Card enabled for an AMD OpenCL System. Just see if you get the Vanilla Blender running on the mac. And test if you get white clay Renders. If that works i can guide you through the steps to get the rest working.