Cycles Hair Rendering in the Wrong Location

Hey Everyone,

I’m working on some hair in Cycles, and following Kent Tramell’s awesome tutorial from Blender Cookie, and I’m running into a strange issue.

As you can see below, I have the hair styled over the scalp in a certain way in the Particle Edit Mode. If I render it in the Viewport, it’s styled the same, but if I do a full render, some of the hair sticks out at odd angles or is misplaced.

At that point, if I exit the full render, Object Mode shows the hair still misplaced. However, if I go back into Particle Edit Mode, the hair immediately resets and looks like it should, even if I go back to Object Mode again.

Any idea what might be causing that?

[ATTACH=CONFIG]264897[/ATTACH]

I’ll take a couple swings in the dark, short of that post the blend. I don’t think it’s a children issue.

  1. I saw something very similar a few weeks ago, and increasing the path steps solved it. In the hair system, in the render section right below b-spline, increase path steps to 6 or 7.

  2. Is is possible that you have a second hair system which you have set to hidden in viewport only in the modifiers tab. (the eyeball)

beyond that post the blend. And the hair looks great btw. I followed that tutorial and it’s really great.

Thanks for the response, blenderallday.

I’ve had the path steps set to eight during the whole modeling process, and it’s still set to that now, so that wouldn’t seem to be it. It’s good to know that can cause issues, though.

I’m not seeing anything hidden. I’ve attached a blend file with nothing but camera/lights, the scalp and its two attached particle systems. This issue was showing up before I added the second system (Hair Key), and I haven’t noticed any difference after adding that.

I did just notice that after rendering reveals the misplaced hairs, switching to Edit Mode on the scalp resets the hair as well, so it’s not just switching to Particle Edit Mode that does it. I haven’t tested it yet (would have to re-render each time), but I would guess switching to any other mode resets the hair.

[ATTACH]264941[/ATTACH]

You have a subsurf before the hair systems in the stack, which is fine. But you have the subsurf hidden in viewport and not hidden for rendering. The subsurf changes the direction of the normals and will change how the hairs emit out of the mesh. So either just remove the subsurf, or click the eyeball and re comb the problem hairs. Viewport will now match render.

You could move the subsurf to the bottom of the stack, but ultimately I think it’s better to have it at the top, as the hairs will emit in a smoother range.

Dark grey is enabled, light gray disabled (hidden)

1 Like

Aaaahhhh, forgot about that. I made the scalp by duplicating the vertices from the head, and forgot about the fact that the subsurf would duplicate as well, even after making it a separate object. I think I’ll just remove it.

Good catch, and thanks for your help!