Cycles Hair Renders Darker than Viewport

I’m having a problem with Cycles hair rendering: when I render the hair, the rendered image is darker than the viewport image render (shift-Z). But, if I render just the head, both images are the same.

Here are the settings:
Color Management
-Display: sRGB,
-Gamma: 0.00
-Exposure: 1.00
-Render: default
Render Panel: under the “film” tab, I have “transparent” selected, and the exposure at 1.00
Environment Lighting: pure white, 100%, also checked “environment lighting” in “layers” panel

Any ideas? I’m stumped!

Well in my experience with cycles, the number of samples can sometimes make some effects darker or brighter. Try changing the number of samples in your render to match the preview samples, and change the hair preview density to 100%. If they look the same then you’ve found your problem.


For the renders above, I have the render and preview samples both set to 10, the “display” to 100% in the particles window, and the render and preview number for the children both to 200.

Could this be a bug?

Could it be that this is due to some light being masked out or not shown during render?

I think child strands don’t render in the preview window, even with the display setting at 100%. At least that’s what I’ve noticed

Thanks for your input, everyone. I still haven’t solved the issue, but since I’m already rendering the hair on a different renderlayer and then combining it, I will just up the brightness in the compositor.
An unsolved mystery… If I find the solution, I’ll post it here!