(Cycles) Hide emiters in scene but view in rendered 3d view?

Is there any way to hide emitters as they block the model but still have them rendered in the 3d view rendered mode?

you have to deselect camera in the ray visibility object panel.

That is only applicable to actually rendering. I am talking about hiding the emitters in the 3d view you are using for editing your scene/models, while having these emitters affect the lighting in the 3d view that is set to “rendered”. Otherwise, the workflow becomes:

Edit some stuff on your model
Re-enable the layer that has your emitters to view the preview in your “Rendered” 3d view.
While this may seem like a small thing, it’s a needless inconvenience and removes the convenience of making changes in edit mode and seeing the results dynamically.

Fundamentally, the issue is that the “Rendered” 3d View is bound to the settings of the 3d view panel and scene. It ought to be unbound to your actual 3d view editing panel(s) as it is in fact quite different. Then one can enable different layers for the “Rendered” 3d View and your standard 3d Views.

I really do believe this change needs to be made and will be submitting a request to the issue tracker or whatever blender uses for development. There is no reason why the rendered 3d view should be bound to the editing 3d view(s) as one would often like to see the actual composited render as opposed to whatever one is editing at the moment.

This is on 2.65.1, maybe this is fixed in nightlies/RC.

Hi :slight_smile:
You can always try setting the display type to wire in the object settings. That way when in solid view you only have the wireframe view visible. But in rendered view it’s solid and textured.



Hope this helps :slight_smile:

Thank you that is quite useful. I have submitted this feature request on the developer mailing list and I think it should be implemented. It would be nice to have additional advanced configuration parameters to the rendered 3d view anyway.