Cycles - how to make "video" animation without fireflies

Hello,

I am trying to do a fly through of a retail like setting in cycles - as it’s better looking than the internal engine - and yet I am unsure as to what settings to keep the fireflies down to a minimum.

If it helps any I am using Blender 2.69

To keep the fireflies down to a minimum you can brutally use the clamp function into the “sampling” panel, also increasing the render samples could improve the result at cost of rendertime…

Also should help with fireflies:

  • turning off caustics (if you don’t need them);
  • Turning on multiple importance sample for the sky;
  • Migrating to branched path tracing (if you use the svn blender version) with a more precise sampling configuration;
  • Using a bilateral blur in the node configuration for the compositing (if you don’t mind so much the details);

And of course using every trick explained here: http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/Reducing_Noise

Hope it helps
Sparazza

One thing that really helps is to animate the “Seed” value in the render settings. The video codec will smooth out some of the noise from frame to frame if it doesn’t appear in the same pixel location on every frame.

Hmmm… I just realized I don’t know if it’s possible to animate the seed because I’ve never done it. :smiley: Any way… Don’t bother. A long ago, I saw somebody use this trick: Just type #frame in the input box for the Seed and it’s done. (The input box will turn to magenta, as if a driver was used… but you don’t have to do anything more about it.) After that, Blender will use the current frame number as seed.

Great shortcut Kaluura. It is in fact adding a python driver though, so make sure to enable python scripting. Auto Execution is off by default in recent Blender releases, so put a check in the Auto Execution/Auto Run Python Scripts box, which in turn is found in the Preferences (File tab).

Alternately you could use a different render engine. If you are stuck using Cycles then remove all glossy shaders, they are a major culprit of erroneous output.

as it’s better looking than the internal engine

A dubious statement at best as you can see you are fighting the technology just to get acceptable output.