Cycles: huge white dots problem, scene included

Hi everyone,

Cycles brought me back to Blender again. The first impressions are incredibly positive, but now I’v hit the first roadblock:

In the attached image you will see horrible, horrible fireflies (or white dots). It’s probably due to the liberal use of a glass material and indirect lighting, but these are just necessities for this scene.


I played with pretty much any setting in the integrator and none had any positive effect on the dots.

I attached the scene so you can try to render it without artifacts.

droplet_011.blend (1.34 MB)

Blender Version: 2.60.5 r42025 with Cuda support.

Any help is appreciated.

Great job, and great tip! Thanks!

Thanks for the tip, may have the same problem and will try to fix it!

B.

There is also another way to fix the problem with the white dots: Just go to renderoptions>integrator and check “No Caustics”. In addition there is an option to filter the reflections underneath, but i found it is unnecessary to deal with it…

Hello, I found another one, which works very well for me (while “no caustics” did not): set Clamp to something more than 0, in the same “Integrator” area. 1, 2, 5, 10, … you can test it out. 0 means no limit, and this seems to result in speckles.

1 Like

I confirm ~patb solution worked out for me.

I just made an eyeball somewhat according to a tutorial,
but when rendering I got a whooole lot of fireflies on the glass material.
I heard about setting the Clamp value to 0.98, but that
completely killed the strength and contrast in the lighting?
Any suggestions how I get the same light effect with the new clamp value?

This is the rendered picture with 1000 samples 100% resolution
http://imgur.com/3wsQdlTand this is how dull it got with clamp value of 1
http://imgur.com/yaTg9X4

What the fuck :frowning:

Im completely new to 3D programs so Im sorry if the question is retarded haha…
All help appreciated,
Lisa

Hi, when increasing the clamp value to 0.98 which I heard was good,
the strength and contrast in my lighting completely died!

without clamp:
http://imgur.com/tenfLin,6HMtVwe#1

clamp value of 1
http://imgur.com/tenfLin,6HMtVwe#0

Im sort of new to rendering so I might be retarded, but:
how do I compensate in other settings to keep the contrast while having a clamp value?

All help appreciated
Lisa