Cycles Image Textures with alpha map transparency creates black shadow outlines

Hi all. First time posting with an issue that’s killing me. :slight_smile:

In cycles, transparency usually works flawlessly whether it’s part of a mesh or just a plane with an alpha map. But this latter case poses a problem I’ve encountered numerous times with no solution.

When you have a single plane with an image with a mix shader displaying the image texture for the alpha area but transparent otherwise (standard option when adding “image as texture”), no issues. BUT once you stack a few on top of one another, there is a black shadow extending to the end of that plane mesh that I can’t get rid of. What’s more perplexing is that this only happens in CERTAIN ANGLES and from other angles, it all displays just fine. The most troubling part is that when you look from the front straight on, you just can’t avoid seeing all the black shadows.

I’ve tried everything from setting up another mix shader node with another transparent shader and telling it to go to the transparent one when it is shadow ray to turning off shadow in the object’s ray visibility, and even telling the lamp to not cast shadow. None of it works.

But to explain better, I’ll just post a few example pics to clarify. I’m new to this so I don’t know how these will be displayed exactly, but since I can only post three pics per post, I’ll make another upload after this.


This is the node setup.

This is what it looks like looking straight at it in cycles.

This is what it looks like once the same object is stacked on top of another (using array here).

If anyone can shed some light on this annoying problem, I would be much obliged. Thank you.

In the Render / Light Paths settings what have you set the bounces for Transparency ? Try increasing it

2 Likes

Hi Richard. Thanks for the reply! I am not really a novice in Blender but I don’t know where that setting is. In my Light Paths, the only types that I can change the bounces are diffuse, glossy, transmission & volume. I am using Blender 2.72b and again, this is in cycles rendering. Perhaps that’s a setting that exists in Blender Internal? But if you can direct me to where I can find it, I’d be happy to try. I’ll keep digging around. Thanks!

Also, it being my first post, I had to wait until it was approved and was not able to upload the other example pics earlier. Here they are:


This is still viewed from the front but slightly angled - you can see that it only displays for certain angles.


This is a side view of the stack.

That was it! Haha. Thanks, Richard! i don’t know why my earlier reply isn’t posted yet but it’s probably still because I’m new. But like an idiot, I didn’t see the big transparency bounce section all by itself. I’ve honestly never changed this or heard anybody mention changing it for any reason so I never looked at it in the thousands of times I’ve looked in that very panel. It was set to 8 max and 8 min, which was the default, but changing it to 40 max did the trick (not this example but a more complicated scene I was dealing with). Thank you so much!

This is really late, but thank you for this!