Cycles is rendering invisible objects

I setup my scene with the low polygon model. Then when rendering I noticed that the high polygon model was in the scene. I checked the hierarchy and scene, and the high polygon model was invisible. I had to move the high poly model out of view.

Did you use these ray visibility checkboxes to disable it in rendering?
If not, try disabling all 6 so that it does not appear.

Just to be sure: You do realize that “invisible” (eye icon in the outliner) does not equal “unrenderable” (camera icon in the outliner), yes?

1 Like

I’m sorry I didn’t get back to you. I don’t have the scene anymore, nor the snake.
I think you are both correct about the invisible rendered object.