Cycles Liquid change Obstacle Colour

Hello, I have a problem. I should giving the .blend file to guess the value I set for everything but I can’t do that.

I have a liquid flowing inside a object. Liquid material made with Cycles Glass Shader IOR 1.333 and nothing else.
The animation works fine, but the render is not.
The liquid is fine and the material too, the problem is:
the obstacle’s material changes upon contact with the liquid. it is a Glossy/Diffuse material.
is the obstacle supposed to change color?
can I avoid that? (or at least reduce it)

http://imageshack.com/a/img706/1435/i772.png

If your .blend file is too large to attach, post it to www.pasteall.org/blend/ and give us the download link. If your file contains some proprietary material that you can’t share, create a file that demonstrates whatever you’re having trouble with and post that instead.

It looks like your obstacle’s material isn’t changing color but rather the fluid’s material is not transmitting light well. There are sometimes problems with glass materials appearing black because of transparent shadows. You may want to use this material setup instead: http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/Reducing_Noise#Glass_and_Transparent_Shadows

If that’s not the problem, then we need a clearer screenshot and a better description. And, preferably, a .blend file.

that’s it! :yes:
Thank you very much, I will post another sample of the result to show other the difference with the node setting you suggested.