Cycles materials alpha is not rendered correctly.

I have a material that I want to animate the alpha channel of the diffuse and glossy so that it disappears.

When I tried to test it the material still renders even of the alpha is set to 0 for both nodes.

I’ve tried several things but can’t get it to work.

As an alternative I added another mix node and a transparent bsdf and I can use the factor to make it transparent but it still casts a shadow.

Even if I set objects camera visibility shadow to off it still renders a shadow.

I don’t know what else to try.


strange… a transparent bsdf with a (1.0,1.0,1.0) color should cast no shadows… unless you have the transparent shadows off.

Check in your render settings, Light Path section, and check the shadows option bellow the transparency bounces.

Perhaps you could provide a file demonstrating this problem so we don’t have to guess what’s going wrong.

I figured it out finally.

First a material with just a diffuse with alpha set to 0 will still render no mater what I do. You can verify that with the default startup file. just create a plane to catch the shadow and setup a cycles default materal and change the alpha to 0. press f12 and it will render the cube.

The problem with the diffuse and transparent through a mix node was cause by me when I was trying to get the diffuse to work as I expected. In the process of trying different things I had turned off the transparent shadows in the material settings. That of course cause the shadows to render even if the object was transparent.

I guess I just don’t understand why the diffuse node with a zero alpha renders. I am still new to all this and am learning every day. Sometimes it seems so frustrating.

Thanks for your help.
Happy Blending

Ok. I guess I spoke too soon. The object is now transparent and there is no shadow. However the point of this is I have 8 objects (several texts that was converted to meshes) that occupy the same space. My hope was to animate the visibility and have them fade in and out during the sequence.

The shadow is now gone but the transparent objects are causing noise on the visible one at the points where the surfaces of the meshes intersect.

Increasing the number of transparency bounces in the render light paths helps but even set for full global illumination the noise is very noticeable. Perhaps because of the glossy node in my material.

At this point I think I am going to have to find another approach to achieve the effect I am looking for.

Animate render visibility as well… this will help with the noise intersection areas.

BTW, that alpha setting you are referring to (Material > Settings > Viewport Color/Alpha) has nothing to do with alpha transparency for that material in the render. It’s just for alpha transparent display in the solid shaded viewport (e. g. if you want to indicate a transparent surface in OpenGL) and will furthermore only work, if Transparency under Object > Display is checked. Just to avoid further confusion about this setting.

The Alpha setting I was referring to is not the view-port alpha it is in the color picker. The view-port alpha works just fine.

You really need to post either a blend file of a screen of your nodes for that material. Something at full transparency should not cast a shadow.