Cycles missing Device option

Hi everyone.

I know some don’t really like new users who come to a forum with the question as their first post, but I’m about out of ideas and am nt sure what to do next.

I’m trying to check out Cycles and I got it running, but I heard it had OpenCL support.

I’ve downloaded this version here.

That’s Blender 2.6 with Cycles+CUDA+OpenCL+SSE2.

Now when I’m in Blender, I want to change to GPU, but I see no device option.

There’s a screenshot of what I get.

I’m running on a Win7 32 bit with an ATI Mobility Radion 4500.

Does it just realize my card’s not good enough and just not showthe option at all?

I saw another post on here saying to check the console.
In older versions of Blender, this was in a separate window… but now it’s not. When I open blender, I see it for a second, then it’s gone. It’s not in the taskbar or anything. When I close blender, I’ll see it again, but while Blender is open, I just don’t see the window anywhere.

Where did it go?

So long story short:

  1. Where’s the Device option in cycles or why isn’t it showing?
  2. Where is the console? (Not the python one, but the log that shows all the functions that Blender is doing?


If your card doesn’t support CUDA or OpenCL, then you will not get the device menu. You can also activate the console by selecting Toggle system console from the help menu.

Your card is not good enough to use cycles with OpenCL and its not an NVidia so cannot use CUDA

Ah I see. THanks.

Man I hate this dumb card. (This isn’t the first time I’ve run into issues like this.)

It’s so hard to find a good card in a halfway affordable laptop. :\

Oh well, thanks.

I’m getting my desktop back soon and that has an NVIDIA GTX 560 with 2 gigs of RAM, so I should be all good then. Thanks again guys.

Hopefully in the near future I can help others with things here as well.

There is another console you might be interested in,it was available(don’t know now) above the top bar (on the same bar as Add/Files/Render menu lie).Drag it down.

One thing …What is the Benefit of a SSE2 optimized and what it supports.?
Is it like open mp which also i really don’t know much about.

Not sure exactly what SSE2 does, something to do with CPU speed or something.

Well I recently updated my graphics drivers and now it shows up… but now I get this error saying that something’s at 1.0 and it needs to be at 1.1. It appears that this is a problem with Cycles as others have goten this and DingTo just said not to use it for now. And anyhow, OpenCL only does white clay looking renders for now.

All that aside, I’m back on my desktop with a GTX560 and I can get about 550 passes in about 10 seconds which isn’t too bad.

Can you tell me how is your viewport performance is with 560 ? Can you sculpt, how many poly (faces) can it show. Because i’ve been warned about the performance of 560 or the whole of 400 &500 series nvidia cards about the open GL slowdown because of the some driver issues.
It would be a great help.

OpenCl support is under development(only clay render materials have been defined). and its better to use CUDA ,i suppose.

Well I only use blender on and off, so I’m afraid I can’t give you all the super details. I use the 560 with 2 gigs of RAM. The CUDA in Cycles works rather well.

As for openGL support, I’m not sure as I didn’t really do too much in it. I’ll look up a sculpting tutorial and mess around with that in a bit and let you know how it works out.

But as stated, the GTX 560 with 2 gigs works fine with CUDA in Cycles. I pulled in a model from DAZ Studio with about 70-100K polies and it works out nicely.

woops didn’t mean to post and don’t know how to remove

Hi everyone,

Hope I’m in a right forum, but I have same problem.
In my case, my graphics card is GTX 295, so it has shader model 4.0 and CUDA enabled. I render on other GPU render with this card and everything is allright.
In case of cycles, I have no device option in render setting of blender.
Can you help with that? Is GTX 295 somehow not supported?

Thank You in advance :wink:

Look in User Preferences / System

Solved, thank You very much, Sir.

me 2 :smiley: rendering the start-up scene in 0.59 seconds as to 1.31 from blender 2.61

gtx 560 ti 1gb i’m getting about of 700k faces in sculpt with a hint of lag :slight_smile:

not bad … :slight_smile:

This is true? Because I’m not using Nvidia (I have a Radeon 5750), I can’t use the GPU to render in cycles?

OpenCL is not supported in AMD cards just yet, only on NVIDIA cards… supposidly they have a new OpenCL drivers out soon which will fix the compiling option…