Cycles Motion Tracking

I’m new to rendering with cycles and can’t get the video to show up in the compositor. I’m not changing the automatically generated nodes when using the motion tracker so everything is as-is. Looking at the compositor the movie stops showing up in the nodes at the alpha-over to the rest of the scene. Is there something I forgot to do because I’m using cycles and not the internal rendering engine?

Did you check the box Film->Transparent in the Render panels? This sets your scene’s World to transparent.

Thank you that fixed it. One more question: how do you get the ground to just recieve shadows and not show up like using the blender internal?

Unfortunately, as of now I think using the compositor in BI is the only way to make a shadow catcher. Render your foreground plate from Cycles with alpha, and in BI composite those images over geometry with a Shadow Only material.

I missed it the first time around – the motion tracker automatically generates a node tree? Wow.

So am I right in assuming you can’t use a transparent material and trick it to recieve shadows in cycles? I usually run into that issue when I’m using BI

Nope, the rays pass right through a Transparent shader in Cycles.

Alright then I’ll keep working on it a different way, thanks for your help!

I found a way to simulate (hack) a shadow pass in Cycles, by making your shadow-casting object invisible to the camera. Select the casting object and go into the Object context in the properties panel. In Ray Visibility, uncheck Camera. Now you should only see its shadow on your receiving plane. To make this “shadow pass” useful as a mask you’d have to make the receiving mesh pure white and light it with high intensity, but it should work for compositing. Like I said it’s a bit of a hack.

Probably this is not a perfect solution, but instead of shadows You can use AO. For example do something like this:

Attachments


Could you explain or point me to something that shows how to use AO in cycles? I can’t find anything or figure it out myself.

I think would be best if you download the sample file and look at the node editor.

Attachments

cyclesaotest.blend (626 KB)

^^^May I ask which build are you using for that? There is no AO pass available in my official 2.62.

My mistake, I forgot to say that I have used the development version - http://builder.blender.org/download/

My mistake, I forgot to say that I have used the development version - http://builder.blender.org/download/

Third attempt to answer, maybe this time will not be blocked by the moderators - I’m using the development version from the blender site.