Cycles Node Setup Help

Hello,

I have this UV Sphere set up with a world map alpha texture mapped onto it. I’ve mixed a diffuse and transparent shader together, using the Alpha as the mix factor. I do not want the faces with the backs of their Normals showing. Essentially, I want the faces whose Normals are pointing to the camera to be shown. The transparent areas should show the background or whatever’s behind the sphere and not the backfaced Normals.

I’ve played around with Backface Culling and such, but cannot seem to get the desired effect.

Blend File: https://www.dropbox.com/s/grriuri8788lwb2/World.blend?dl=0

Hi,

you need to uncheck “double sided” in the object data tab, under “normals”.

That’s unchecked by default, and either way it doesn’t seem to do anything.

I could change the End clipping of the camera to show only the front half of the sphere, but that still isn’t what I’m looking for…

Wait, hmm, that is a good one.

Something like this?



There it is, nice.

Thanks! Apparently my problem was using the Backfacing on the first mix node. Thank you all for the help.