Cycles noisy bakes

hi all :slight_smile:

There’s no proof needed to show cycles is an noob buggy renderer…
And the main problem with that it’s the only renderer available in blender.
The second main problem is that if i don’t use 2.8x blender, i’ll never get cycles debugged.

Then…
With the shi**y 2.79 cycles ( yes, am a neanderthal using 2.79 ) , could anyone please tell me how to get rid of diffuse bake noise ? or even simply enhance baking quality… ?
I mean… the noise coming from other objects in the scene…
errr yes :slight_smile: it’s possible :stuck_out_tongue: anything is possible with a buggy code ^^

Lemme explain…

Here’s a bake from a mesh:

There are light emitting meshes, and on the left you can see the bake result.

Now let’s add some buildings, around this room, bake it ( changing nothing ) and see the result:


If i had blender render, i’d say LOL CYCLES !!!
but i don’t… :face_with_symbols_over_mouth:

Here’s the blender file ( i hope i forgot nothing in it ) so that you can test it…
http://kleioscope.fr/exchanges/shitty_bake.rar

please anyone ! could you tell me wether i do things wrong and how i can do them better ?
please ?

Thanks in advance to the community !!!

and happy ( not always ) blending !

noone got idea on this bug ? :open_mouth:

There are some linked blend files missing in your rar:

owww :frowning:

sorry for this ^^

lemme correct the thing and send it back asap…

Thanks @SteffenD :slight_smile:

EDIT: there you go @SteffenD :slight_smile:

happy blending !

How about you pump up light samples in render settings?

Yes, it’ll take longer. But will also be smoother.

i guess yes but if i need to mul by 4 samples each time i add a cube in the scene, i’ll finish with 100 million samples needing 25 years to render :wink:
On a ryzen7 i expected a lil better performance…

Btw when i bake only the room, the result is okay ( and i agree doubling the sampling would enhance the result ). My question then is why the addition of surrounding objects f*cks up the bake result ?
maybe i do some things wrong ? something i missed ?

baked with 4096 samples. The bake took 6h…

And the result is still very noisy :frowning:

Any advices ?

wowowowoh…

I made some tests on a separate file…
It looks like when the objects around the one to be baked, are linked objects, with linked material, the bake goes very noisy ( mostly like if the linked object material bothers the bake light rays ).
When setting the material of the linked obj to a normal material ( eg not coming from a library ) the baked texture appears less noisy…

some captures:


This bake is done with 128 samples ( not much but enouth for tests ) and render time takes 5 minutes.
The material come from the linked blend.

now… let’s change the linked object material to a local material…

This is weird and smells like a bug: linked objects materials fu*k-up the baking process…
I know this will be a feature of 2.79.6 and will never be corrected as 2.79.x users have to get lost but am kinda glad i discovered this ( after 4 days of struggle in baking ) and found a vorkaround x))

Now i know that in final quality baking ( 512 samples ) my result will just look perfect :slight_smile:

happy blending !