Cycles: Noisy Render when setting up a test scene.

Hello, I’m fairly novice with Blender and Cycles. I’m trying to do my first animation, but I’m running into issues with noise. Typically, I can render a minecraft scene with around 150 samples and not have this much noise, but when I roughly set the material for glowstone (emission on lighter parts of the texture), the scene began to render with considerably more noise. I tried rendering with 2000 samples and still had a noise problem. I’ve attached a render with 500 samples, as well as my .blend file and textures (Scene.zip). I’ve already tried various things, such as messing with light bounces, node setups, resolution, and toggling ‘No Caustics’, so some of these values may be in odd places. I haven’t gotten better results with any other settings. I could always increase samples, but I need each frame to render in under 3 minutes unless I want the animation to take more than 20 days to render. The 500 sample image rendered in 11 minutes. I’m guessing that the problem lies somewhere in my glowstone material.

Thank you all in advance,
-Zach

Files:

Pack your textures. All I see is a pink mess…
Also, why on earth would you make the point of origin the same for all objects?

I wouldn’t/didn’t. The objects were generated by an algorithm called jMc2Obj (converts Minecraft worlds to .obj files) which I textured afterwards. I included the textures, but perhaps the file paths have changed. How would I “pack” textures, as you’re suggesting? I’m still fairly novice with Blender.

File > External Data > Pack into .blend file

Alrighty, I uploaded a file called Scene01.blend, which I believe has the textures packed into it. Let me know if that does not work for you.

EDIT: Please ignore. I was still ranting… err… typing while several posts came in. :wink:

My apologies for making that mistake. I did not know one could simply pack their textures. I have addressed the problem and there is now a packed .blend file in the same folder I linked in the original post. Click that link again and download Scene01.blend. If I have done something incorrectly, please notify me.
EDIT: Alrighty :slight_smile:

I dont see the problem here. I set the render to 500 samples and got a decent image. It does need more samples though…
The only thing I changed was to uncheck Progressive Refine and set the tile size to 16 since I cu render.


I normally get the same amount of noise if rendering with 10-20 samples, though. It wasn’t like this until I made the glowstone emissive.

Changing the glowstone to diffuse-only and brightening the sky/atmosphere significantly improves the render. 20 samples with diffuse-only glowstone looks better than 2000 does with emissive glowstone.

EDIT: Here’s 20 samples with non-emissive glowstone and a brighter sky:


Well, yeah…your adding more light. Ligting it with only the emission is going to take more samples.

Alrighty, thanks. Now I know the cause of the problem. So what are my options if I wanted a night scene? I can’t have 2000 samples for each frame… it would take approximately 300 days to render a 5-minute animation with 2000 samples on each frame if using my computer.

Small lights with big power means lot of noise. So, here is what I did: I reduce the strength of the lights to only 20 and I compensated by increasing the exposure to 2.5. I also tuned a bit the bounces, inspired by the “Direct Light” settings. Transparency and Bounces: Max 3, Min 1. Diffuse 0, Glossy 1, Transmission 2. At only 800 samples and in 3’18" on my little GTX 560, I got this:


Still a lot of noise. These damn lights are too small…

I also made the “midday test” like Smalltock, but I kept the lights on.


Much better! It won’t be the same, but I’d go for midday. Fighting with noise is exhausting. :wink:

EDIT: I almost forgot… I also tuned the materials. There are tons of them which don’t need any kind of transparency but mix the Diffuse shader with a Transparent shader any way. That’s a total waste of time for Cycles.

I suppose that’ll have to do. The mid-day render looks great! :smiley: I’ll still have to tone things down a bit, though, since my graphics card isn’t quite as good as yours.

I could actually try surrounding the glowstone blocks with invisible spherical mesh lights, which can be much larger and softer. I’m going to try it in a little while.

Try using the actual ‘Light’ objects instead of mesh’s… I believe they are a little bit faster.

I’ve found a new potential solution involving compositing and a new material structure for the glowstone. I will post details tomorrow, but for now, I’d just like to know which of these looks better overall. The second has bilateral blurs that the first does not have. Both scenes were rendered with 120 samples and both have the new glowstone material.




EDIT: The link in the original post now has an updated Scene01.blend … look at the glowstone material in there if it matters to you. You can also look at the compositing setup (poorly done, but it works, atleast)

Hi Smalltock, I see you have marked your thread solved so this little bit of advice may just be too late! But I noticed when I finally opened up your file that your world was set to black color and a low strength, it seemed to render with less noise and faster with the background removed entirely and with no difference in the output so I just thought I’d let you know…

When you have the world set up like that the first few passes make it seem like it will contribute something to the final image but I have noticed that in the end it only makes things noisy.
Instead you might download a recent build and render an environment pass (after making it brighter) and post process that!