Cycles Normal Map Bake Issue

Hey guys,

I’m getting these strange streaks / triangles in my normal map bake. My object is super simple (flat cutout) but I can’t seem to bake this correctly. I’m using an image in the Displacement which looks good in render but it bakes like this…

Thanks for any help!

This issue went away when I upgraded to 2.77 from 2.76.


Here’s a completely different object but I’m getting pretty much the same issues… just worse here. There has to be something I’m missing about baking Normals. These maps are unusable. :frowning:


Hi son, here’s why nobody answers: YOU…DID…NOT…UPLOAD…YOUR…BLEND FILE. People hate wasting their time randomly guessing especially when you could make their life so much easier by UPLOADING YOUR BLEND FILE.

Really? What would you possibly get out of seeing the blend file? Make a box, put an image in the displacement and bake the normal.

I’ll upload the blend file when I get back to my workstation. I’ve been using Bitmap2Material to get a decent normal so it’s not slowing me down, I’m just curious as to what I’m doing wrong.

the blend is NEEDED because we have ZERO IDEA and ZERO information on the image you are using for a displacement

for all i know it is a red,gree,blue jpg shaded image
and NOT
a 16 bit height map

add the images you are using to the blend

and the GUESS i am making
is this

you are using a VERY compressed *.jpg image
and the artifacts ARE causing problems
and the jpg is a color image and not a black and white height map

Just like that? well… that will be a flat (0.5, 0.5, 1.0) as expected, and not even near your result.

Even if I create a hires box, with displacement, and a lowres box, bake selected to active with proper ray distance, still gives me a nice result.

So there must be something you’re doing wrong, and since we cannot see it through the images you’ve posted… we cannot really help. :frowning:

I’m just trying to get the same result I see in the render. The image for the bump is low res but it works fine in the render… especially at the distance I’m going to be looking at it.

Here’s a link to the blend with the images embedded…

Thanks for helping out guys. I realize completely that it’s something I’m doing wrong. I was hoping someone here would see the bake and say “oh yeah, that’s a common problem. Just turn this on” or something of the sort.

This blend file has the Normal I got out of Bitmap2Material so jsut plug the other one in… it’s called ChalkScoreBoard_Bump.png. That’s what I was using and got the above result.

Actually… I just baked using that Normal map and got the same crazy result so you can just select ScoreBoard_Normal and hit bake to see it.

Parts of your UV map is just way off. Some islands are overlapping and poorly unwrapped.

What the heck!?! I thought I was careful… let me look at this thing again.

also the normal map is the negative of the bump map

in the bumpmap the etching on the chalk board in DARKER - hence farther away
the normal has this area CLOSER

I can fix the normal easy enough… that came out of Bitmap2Material so you just invert the tangent in there.

Can you guys take a look at one more blend file and see if you can figure this one out? It’s the top image I originally posted. I don’t see any issues with the UVs on this one but I still get these crazy triangles.

Thanks so much btw. I feel dumb for the chalkboard one. I was moving sections of the UV around and didn’t realize I was messing up something else.

Delete your cage mesh materials.

(In case of such simple geometry you don’t even need a cage mesh, a simple ray distance is just enough.)

I made the cage in an attempt to solve the issue. Are you getting a decent bake without the cage?

Yes, I get decent results with and without the cage. I did not modify anything in your file.
Without the cage make sure to give a long enough ray distance (e.g. 0.1 this case)
If you use a cage make sure it has no material (that could modify the normals) and make the shading smooth.

Hmmm… I turned off the cage, upped the ray distance to 0.1 and my bake looks the same with the same triangle issues. The triangles match up to the UVs so it makes me think something is wrong with my UVs again but you say you get good results? How strange.

Download this and only hit bake.

I get this:

I get the same issue… (this is the lower right corner of the image)…



I just looked at your bake image… that isn’t what I get with the exact same file. I did have to unpack that image because the bake was giving me an error but that shouldn’t matter right?

What version of Blender are you using hellofamesh? I’m still on 2.76. Maybe I should upgrade.

2.77a (latest)
Try assigning a new image to the material on the low-poly mesh.

Maybe this helps.
I wasn’t quite sure which is what and where however normalmaps and not smooth high poly (or 90deg angles) newer quite work.
Again- do not connect Normalmap node output to Output node’s Displacement. This is not how it works.