Cycles not rendering larger scenes


(Jay-artist) #1

Hi, I posted this elswhere, but it’s probably better here.

I recently created a bathroom scene and as I’ve begun to add more detail to it, it’s stopped rendering in Cycles. It’s not the first time this has happened, originally I just put it down to an old beta version.

Anyhu, what happens is that blender does the BVH percentage up to 100 percent and at the point where it should start to render out the image, it just finishes with a black/empty image.

I’m Using:
Blender 2.61 64Bit + Cuda
Win7 64
Core I3
7 GB Memory
Nvidia GeForce GTX 560 Ti

The scene doesn’t appear to be that big compared to others I’ve created for BI - is there some sort of limit I’m not aware of before Cycles just can’t be bothered to try and render?

This is a real pain, as I need Cycles to render more complicated scenes than this, the scene right now is only two thirds done!


(storm_st) #2

If you using GPU, there is limit of onboard memory, that need to hold BVH texture (and other). In theory, some adapters can reuse main RAM, but in practice there is limit. Maybe new driver update will change it. Try CPU mode, if it not render too then file bug report.


(Atom) #3

I have seen that happen to me when I don’t have any lights. Lux actually checks if you have any lights in the scene, but Cycles seems to merrily process the scene without them.

The 560 has 1GB of video ram, right…?


(JuanJosé Torres) #4

Have you tried to render the scene using CPU instead of GPU? GPU rendering will only use video memory, whereas CPU rendering uses system memory. If you can render using CPU, then your problem is probably being caused by the limited amount of video memory (your graphic card’s memory).


(Jay-artist) #5

Hi,

I took some further investigation, firstly by rendering with the preview window - oddly the BVH builds so much quicker and also renders! The BVH is done in less than 30 secs, where as the seperate window that didn’t render takes 3 minutes 54 seconds! I’ve heard that this isn’t unusual, but I wonder why there is such a obvious difference?

Secondly as suggested by ‘storm_st’ I rendered without GPU and just on CPU with a seperate window, and oddly again yes it began to render - too slow to make much use, that’s why I bought the Nvidia card, just for Cycles :frowning:

For ‘JuanJose Torres’, in windows it says:
Total Graphics Memory: 4095MB
Dedicated Video: 1024MB
System Video 0MB
Shared System Memory 3071MB

Other details…
On render window "Mem:60.85M(14.45M, Peak 160.64M)
File size is only 1.72MB
Rendering at 1920x1080 @ 55% - So I’m not pushing blender much really.
The driver I’m using is pretty new: 15/10/2011 - 8.17.12.8562 (Downloaded just before Christmas)

When rendering another model previously - MY Golf Mk4, when I rendered at full res (1920x1080) this would also happen, but I found rebooting blender seemed to fix this issue - although if I did any pre-renders then I had the same issue and had to reboot.

Do you guys think this is a bug? or am I missing something obvious?

Thanks :wink:


(storm_st) #6

Some modifiers have different settings for preview and final render. Check meshes for Subdivision Surface, for example it have “1” for preview and “2” for final render, as i understand it make 4X more geometry data (2x in U and V dimensions). Maybe there are other factors as well, some tricks to improve render speed, it is named Preview for a reason :).


(Jay-artist) #7

Yeah storm_st, I getcha. For this scene I have subds on preview level 2 and 3 for final. Still doesn’t make sense why under CPU it renders though and not on GPU. If it’s a memory thing, first up it should say with an error (unless devs haven’t added that bit yet) - and not just render a still without data.

The other thing is that Cycles is too slow without GPU (Unless you’ve a top of the range Core 7, even then…) - and like I said the scene isn’t that complicated, just not a single model like I imagine most people are testing Cycles with (I could be wrong though).

If anyone wants to test my scene, I’ll upload it somewhere to test - I was going to stick it on Blendswap when done anyhow as a handy resource - as you can never have too much bathroom furniture :wink:


(storm_st) #8

if it’s a memory thing, first up it should say with an error (unless devs haven’t added that bit yet)

It is, but it not easy to find that place, sorry. Maybe there bugs in OpenCL/CUDA driver, not only Cycles code, it not easy task.


(Jay-artist) #9

Hi, I just wanted to post an update after adding this issue to the bug tracker.

Yes it is because there is a memory limit with cycles GPU rendering, and apparently it’s the same for other GPU renderers at this time - GPU rendering is still in the experimental stage. So unless the devs work miracles, it’s unlikely to change for the forseable future.

So I guess even if you’ve a fabulous fast card to render with GPU, you’re still gona hit a limit at some point and have to switch back to yuur old trusty CPU - either that or to BI.

It’s a real pain for me as my Core I3 just isn’t that nippy and I’ve just shelled out on my new Nvidia GTX 560 - it’s my fault though, it is mentioned (albeit in a small sentence in the wiki docs) that memory is an issue with GPU rendering, darn :frowning:


(JuanJosé Torres) #10

“Dedicated Video” is the amount of onboard memory on your graphics card. 1GB, in your case, is a very low amount of memory for GPU rendering, so you will only be able to render rather simple scenes, unless you select CPU as your render device (as stated before in this thread, CPU rendering uses available system RAM).

GPU rendering with Octane render is also limited to the amount of memory installed in your graphic card, so I assume this a limitation in CUDA technology itself, and most likely will stay that way. I may be wrong, though.