Cycles not working on CUDA card

My laptop has a CUDA enabled video card that was working in one of the early versions of Blender before Cycles went to trunk; the trunk version doesn’t recognize it and only offers OpenCL. Anyone possibly know a solution to this?

What graphics card do you have ? CUDA enabled is not enough.

I don’t have my laptop with me; think its a Geforce 550M.

Depending on how new the blender version you are using there are additional options in the User Preferences

I have the same problem. I have the latest drivers and the 550m has compute capability 2.1. In the user preferences, I can select either “none” as the compute device or “OpenCL”, and “GeForce GT 550M” which shouldn’t be the case because my card has 96 cuda cores. In the render settings context, I don’t even see the option to use GPU compute unless the feature set is changed to “experimental,” which makes sense if blender is only recognizing my geforce 550m as an opencl device.

Since this is my only system, I don’t know how it should act normally, but from what the wiki says (here) it seems to me that I should be able to see cuda cards with CC 2.1 listed in the render settings context without switching the feature set to experimental. Ideally, how should it work? I even tried installing the CUDA toolkit and that also did not work.

Anyone have any ideas?

Edit: Running 2.62 stock. Lenovo y470.

if you are under a GNU/linux system you can check if a library is properly linked to an executable by using the ldd utility.

Has this been solved? I am getting the same exact issue.

Windows 7 64 bit. BF Release 2.62 (recent builds from graphical too) GTX560 on in an Asus 6742 laptop.

Do you remember which version this was that it worked?

I have a problem like this as well except instead of just not showing the device blender fully crashes whenever i select cycles as a renderer.

Blender 2.62
GeForce GTX 520
Windows 7 32bit

UPDATE: I haven’t tried updating my drivers since the beginning of the year when I was trying to get this to work the first time. Nvidia has since released another update for the 550m on their website ( ). Now, instead of not even giving me the option of selecting CUDA compute devices, CUDA shows up as an option and I can select my card. When I go to render with it though, it says CUDA error: Unknown error. Will try to post if I can get it working.