Cycles pass through lighting?

ok im having issues… im trying to learn cycles (as i used to do everything through blender render) and i cant seem to get the light to pass through the glass object and effect the shadow i know how to do this in blender render but all i seem to get in cycles is a black shadow… is this not supported in cycles or am i just doing something wrong?
here is a quick photo of the light passing through the stain glass ball and effecting the shadow in blender render.


and as you can see in the next photo i cant get the light to change the shadow in cycles…


how do i fix this?

Try the transparent material rather than the glass one, it works alot better I think. Or a mix of glass and transparent

A sphere will project colored shadows. It’s just not the best shape for that. It acts like a lens and concentrates the light. Still, the first thing you should do for your scene is to increase the strength of the light. (You can’t see anything without enough light…) And make sure caustics are enabled. If you play with glass, you want caustics.


Here, the light is a disc with a diameter of 2 units, strength set to 15. You can see the colors in the caustics and the orange sphere projects an orange shadow. But a window pane alike shape is more appropriate.

Never forget that Cycles tries to be the most realistic as possible, unlike Blender Internal.

yea i already tried that and i also tried to apply something i seen in a andrew price tut but that didnt work either heres a screenshot of my current settings


A sphere will project colored shadows. It’s just not the best shape for that. It acts like a lens and concentrates the light. Still, the first thing you should do for your scene is to increase the strength of the light. (You can’t see anything without enough light…) And make sure caustics are enabled. If you play with glass, you want caustics.

that makes alot of sense . ill give it a try

Ouch! Your glass setting is really insane. I used nothing more than the default glass with a Voronoi texture plugged in the color input.

hmm. yea that setting i had didnt work so i made it simple again… Lol but i did notice that when i checked on the caustics there was alot of lighting settings in there so i cranked up filter gloss to 10 and i got Alot more light to come through but it seems really noisy when do it this way

heres a screen shot with filter gloss at 10… as you can see more light passes through but its really noisy



btw… the reason im trying to get more light to pass through this is because in the scene im working on i have a test tube and its got a sphere based bottom to it and its half full of a blue liquid basicly its got half of a sphere in it and i want the light to pass through it and make a really nice bright blue color in the shadow.
im currrently using a glass shader for both the test tube and the water inside. do you think it would be better to use a diffrent shader

You’re making this way more complicated than you need to for the effect in the first image. Glass mixed with transparent using “is shadow ray” as your mix will do it. Turn caustics off.

um im not sure if i did it the way you said or not but i still cant get it to work.


My mistake, I meant to say glass and transparent. Make sure you plug the cells into the transparent node too.

IT WORKED!!! thanks i dont think i would have figured it out without you :smiley:

Glad to help. Hopefully this will be as simple as turning an opacity button on and off when the hypershader makes its appearance in the near future, but until then we have this workaround.