Cycles: Problems with glass in interior scenes.

I’m doing some experiments with the Glass BSDF surface, using Cycles and an object in an interior scene. Results look like this:

In other words, glass looks like it is fake and black.
Lighting is very simple: One background (World) with a Sky Texture (Turbidity 2.0 and Strenght 2.0) and two emitters (one on top of the table, one on the right). No lamps used.

The same object (the wine bottle), rendered in an exterior scene looks certainly more realistic. Any help on what I could do to improve this situation?
Thank you.

EDIT: BTW, the bottle has been modelled using the solidify modifier (and it has been applied).

Attachments


I have put another object and tweaked IOR a little bit… Same result…


Wondering if this depends on the material settings, the lighting or the rendering settings.

Hi mjordan, the solidify modfier can cause some problems if the settings arent set correctly with with a subsurf modifier + extra loop cuts will be required, it’s hard to tell without seeing the actual blend file, or the wire frame of the model. Maybe you could post up your blend?

One thing you may not have noticed, but the edges on the models look very alaised, i.e. jaggy and not smooth. You might want to turn down some of your lights as they appear to be causing this over-exposure.

Plus on a modeling note, on your teapot, the spout is facing the wrong way at the tip - It would look better if you extruded inside the spout a little to give it some thickness.

For me personally I’d model the interiors of the objects by hand and not use the solidify modifier, using just extrudes. If you’re in wireframe mode it’s easy to see where to extrude to, for such a simple model. Maybe if your interested you could check out the topology of some of my potery on blend swap:

Jay :wink:

beautiful render, by the way. out of curiosity, are caustics enabled? what are your render settings?

Sure, here is the blend:
http://www.pasteall.org/blend/11950

One thing you may not have noticed, but the edges on the models look very alaised, i.e. jaggy and not smooth. You might want to turn down some of your lights as they appear to be causing this over-exposure.

Plus on a modeling note, on your teapot, the spout is facing the wrong way at the tip - It would look better if you extruded inside the spout a little to give it some thickness.

I know my models are bad but I really modelled this scene really fast just to experiment. Anyway, thank you for your advice. I’ll do a better scene next time.

For me personally I’d model the interiors of the objects by hand and not use the solidify modifier, using just extrudes. If you’re in wireframe mode it’s easy to see where to extrude to, for such a simple model. Maybe if your interested you could check out the topology of some of my potery on blend swap:
http://www.blendswap.com/blends/architecture/break-time/

Jay :wink:
Cool, thank you! I’ll check them out.

Caustics are disabled. For the settings you can download the blend file I have provided in the post above.

Hi mjordan,

I’ve just spent 5 minutes on your file - I know the tut which you followed. I understand you just wanted to try out the scene, so I won’t go too much into the modelling :wink:

Avoid using the solidify modifier if you can. Try to re-model the jug for example, or just a simple bowl to start with. Create the inside manually by extruding, when you get to the centre - Press ‘W’ (Specials menu) > Merge>At Centre. Try to keep the topology the same as the outside so that the curve follows it’s shape. Don’t make it too thick, generally glass objects don’t have too much thickness.

On the top edge of bowl/jug etc, create some loop-cuts to tighten up the edges (CTRL+R) - slide them to the edges and leave a little gap.

Next the IOR for the material should be 1.45 there abouts for the default glass.

The scene itself is pretty much all white and nothing in it to reflect - glass never looks good like this.

Try rendering the scene without the sky-texture and the box/room - change the background colour to black and just use a couple of light emitting planes instead, you’ll see a huge difference.

you’ll see in my blendswap files, I usually use a curved L shaped backdrop, this is a handy way to learn the way lighting works in cycles and can give great results without too much effort.

To finish, I’m not sure why the solidify modifier can cause so much trouble, If you do use it, use ‘Even thickness’ and ‘High qualit normals’. I did try re-calculating the normals (CTRL+N) and even flipped the normals, but the issue still remained till I removed the inside - which is what the modifier had created.

Hope that helps, sorry for the length :wink:

Caustics are disabled

That is your answer. Black parts are supressed lights by that settings. There is no difference in Cycles between ambient, diffusion, specular, etc lights, they all just photons bounced between obstacles. All separation is artifical, based by BSDF flag in some shaders, for example ray after bounce from surface “Glossy BSDF” labeled as Specular, but in reality it can work as ambient or diffuse contribution, and always have some very bad side effect, in general it scew scene in all cases.

If I enable them, nothing changes.

Thank you for taking some time to analyze that scene.
I did another quick test. I’ve added the default monkey (which is supposed to have good topology and a good mesh in general).
Unfortunately, the problem is still there. When there are 2 glass surfaces one in front of the other, they’re rendered completely black.
Look at the results:


I cannot say I’m very pleased with glass in Cycles right now, unless there is some setting I don’t know that prevents me to render a decent mesh…

Never change that parameters from default 128, it take time to find issue. Light path Diffuse: 0, you got what you set!


0 diffusion bounces, 2 transmission, it never penetrate glass surface and suppress diffusion component. No caustics cut even more bounces.

That’s what I was thinking too, that somehow there wasn’t enough ray depth to get through the glass. Even though it appears as you have enough set in the transparency area, you may have just limited that by reducing the other settings.