Cycles Render Enclosed

My render time skyrockets when I place the camera inside the mesh itself and run it through in a simple animation. Is there something I can change to make the render time drop? I’d imagine it is largely due to the camera being more or less entirely enclosed in the mesh, but as far as I can tell, this is necessary for my animation.

Thanks!

This is because at the moment cycles is optimized for outdoor scenes, a bi-directional path tracer is being worked on in some aspects, but yehhhhh its a pretty big task.

As for speeding up interior renders, try using the Ambient Occlusion option in the world tab… this will lighten your entire scene also… so you may want to grade it after you have rendered.

Thanks for the suggestion. I will definitely give it a try. Does the geometry not directly in view of the camera have an impact on what is being rendered, or rather the speed at which it renders? For instance, an object behind the camera.