Cycles Render is closer than camera

I am doing a render of an simple object. I maybe messed up my camera setting. The problem: I adjust the camera with ctrl+alt+0 to my current view, that I like to render of my object. But the render is always extremely zoomed in. Changing focal length didnt change anything. Aswell as creating a new camera. (using perspective for sure). Is there another “zoom” option I might have missed? Thanks in advance

To clarify, when you use ctrl+alt+0 you go into camera view, but the render does not match this view (it is more zoomed in)?

Yes. I kind of want to render my 3D-View window. So I can just look at an object, like I do during editing and then just render this exact view.
But at the moment I am required to zoom out a bit to then use CTRL+ALT+NUM0 to get an approxmiate of the distance I like.