Cycles render is only a black screen

Are you using CUDA? Does it say “[x] Samples”? If so your graphics-card might just have run out of memory. Maybe your scene is a fringe-case, where the preview can just be rendered, but the final output uses too mach video-ram.


It gets stuck at bvh 0%, duplicate 0% or well, the bvh increases with like 1% every five minutes (and no it is not a big file, its only a dice made from the original cube)

But now I have also realised that not only is the f12 render is weird, now when i render in the preview, first off, I can see all the edges on the faces :S then when I try to add the subsurf modifier, blender crashes… first time it does like this, have been using the same build for a long time now…

Thanks in advance

Hi I’m getting the same error (see the attached grab).

Renders fine in the viewport, it also completes the render, shows it finished for a second and then goes all black. My scene is very high poly.

Any help would be much appreciated.

I have a GTX 470 and GTX 465 in my PC if that helps.

Thanks in advance.


I was having a similar problem abusing the fluid simulation. Preview with Cycles worked just fine, but rendering just gave blackscreen. Eventually reducing the amount of polygons helped me pull through.

I think many display adapters may become the bottle necks for this sort of thing. Try CPU rendering (painfully slow, I know) and see if it does anything?

Just install nvidia-cuda-tookit

It would be helpfull to get info about Blender version and more important your operating system and your driver version and your GFX card.
You don´t need cuda toolkit on windows, for example.
Try official test builds from buildbot.

Cheers, mib.

It would be intresting to see the console output, because if something isn’t workin in blender the console throws you the message what’s wrong.

Also there’s a bug IIRC also in the 2.61 official, where duplicate objects cause a memoryleak filling your video memory and after a few preview renders it’s not working anymore.

My guess it’s either that or your scene uses too much memory to be rendered on the GPU.

Ok did not now that.
I am using opensuse 11.4 x86_64 and blender 2.61
Console error told me to install nvidia cuda toolkit.
Only problem there is no nvidia cuda toolkit 4.1 for opensuse 11.4 (x86_64) at the moment.
Nvidia -cuda- tooklit 4.0 is not working with gcc45 or higher.

antonvdh, you have to change something in your host_config.h in /usr/local/cuda to solve the error with tool 4.0 and gcc45.

For windows user ther kernel are prebuild, on linux and osx you build kernels on the fly.

Cheers. mib.

Compiling CUDA kernel …
/home/anton/blender-2.61-linux-glibc27-x86_64/2.61/scripts/addons/cycles/kernel/svm/svm_texture.h(45): Warning: Pointer parameters must be inlined, so overriding noinline attribute on ‘Z7voronoi6float318NodeDistanceMetricfPfPS
/home/anton/blender-2.61-linux-glibc27-x86_64/2.61/scripts/addons/cycles/kernel/svm/svm.h(151): Warning: Pointer parameters must be inlined, so overriding noinline attribute on ‘_Z14svm_eval_nodesP13KernelGlobalsP10ShaderData10ShaderTypefi’
/tmp/tmpxft_000059e0_00000000-9_kernel.cpp3.i(0): Warning: Optimizing huge function kernel_cuda_path_trace because Olimit has been overridden;
compiler may run out of memory or run very slowly

Just tried to render the default cube with cycles GPU experimental.
I have a Geforce 9500 GT 1 GB works fine with octane.

sorry had to wait a few minutes something with kernel build?
Anyhow cycles gpu is rendering now very fast !!
This is awesome !

Many Thanks

Please Help: I read the posts above, but I cant get it work…
If I am in the render-viewport, everything is ok, but when I try to render there’s only a black screen…
The .blend is attached, maybe someone could have a look.

schwert2.blend (1.73 MB)

Hi Lhurian, I am sorry, many things are wrong in this file.

  1. Some meshes are disabled for rendering
  2. The mesh emitter normals is flipped in the wrong direction
  3. The world environment is black
  4. Whats about the plane material in front of the camera
  5. Something wrong with the blade material
    and some I don´t found.
    I would start with delete all without sword and wall and setup a Sky Texture world environment to setup your materials.
    Btw. nice animation :slight_smile:

Cheers, mib.

Ok I’ve deleted everything except the door and the sword, you are right, the main part of the door and the whole sword is invisible. But I checked the Object-data (you know, the small cube in the properties window), where can I make it visible? :confused:

But thanks for the fast answer

and what’s wrong with the blades material? Do you mean the small grey line? That’s OK, it’s actually just a test.
The Animation is done with the Game Engine. I just “threw” the sword at the door, and recorded the keyframes :slight_smile:

And what is the mesh emitter normals?
Sorry I’m actually not such a noob as it seems to, but I havn’t worked so much with cycles :slight_smile:

Hi, we always fast here. :slight_smile:
You can switch visibility in 3dview or render in the outliner.
A mesh emitter normal should have a correct direction to the object. In your file the normal directs to the sky not to the sword.
It is not so important for cycles but it is better to have correct normals for e.g. Use it in another renderer.

Cheers, mib.


Aahh Ok thank you, I’ll try

YES it worked… Really great thanks that you could help me :slight_smile:

Could someone help me? I’m making a jump scare animation that I would like to use in a video game. I’m am new to blender and have only used it for a day. The problem is, when I try to render my video, it goes completely black, and there’s nothing I can do to fix it. Could someone help me out?

I have the exact same issue, but no solutions from others work for me, I’m so frustrated with this problem, it has wasted hours of my time :frowning:

I’m getting this too, on blender 2.83 and 2.9 alpha. Using Manjaro/Arch, all up to date.
I don’t actually have a discrete GPU, so I’m using CPU render. (I’m using dual monitors, but as such it shouldn’t make a difference…)
I’m not low on memory (only used 3.2 out of 8 GB max). Everything is normal until I render. Viewport is fine, it updates the BVH, no hidden meshes/modifiers getting in the way… Viewport render’s camera view is also fine, so there aren’t any wierd camera settings messing things up.
I’m not new to blender, I started when 2.8 was experimental, but this is the first time that this has happened.

UPDATE: It’s the exact same thing in eevee. I have no idea what’s going on, but I would greatly appreciate any help.

FINAL UPDATE: Wow. Good job, slinkous. I forgot to turn enable the light in my render.