Cycles Render not rendering Particle hair?

Hey everyone, I have a problem and I have been looking for solutions and trying out what I found online but so far no luck. I have created particle hair with Cycles Render and then I did 2 quick preview renders to see what the hair will look like but after that, every time I rendered the scene, the hair wasn´t there.

  • Using Blender v2.70
  • Using Cycles Render Engine
  • Working with Particle Hair
  • In the scene tab I have all the items visible.
  • I have set Feature Set in the Render tab to Experimental.

Between those two renders I made some minor changes to the hair such as adding a bit of flatness, adjusting the roots and so on. Nothing big as far as I know.

Okay that´s it, have a great day everyone!

Get out of Particle Edit mode, and then render and see.

1 Like

I am rendering the scene in Object mode and the hair is still not showing up in the render.

Are you using live view or actually rendering the image? In live view the number of rendered hairs is affected by the ‘display’ setting in the particle modifier, and it’s usually only a 10th of the final strand count. The full hair doesn’t appear until you press ‘render’ or F12.

Pressed render and F12, the hair still isn´t in the final render.

Are you saying it renders fine in rendered shading mode (Shift+Z in the 3d view) but not in a final render (F12)?
If so, please test it in the testbuild and report a bug.

It doesnt render anywhere, neither shading mode nor final render. But the object is there in the scene.

Please upload an example blend file that shows this problem to http://www.pasteall.org/blend/ and tell us the download link.

Okay here is the sample .blend file with just scalp and one lock of the hair. Just tried it again, the camera is looking at the object but it does not appear in the render. - http://www.pasteall.org/blend/29754 Let me know what you come up with!

In the Cycles Hair Rendering settings you have the Scaling value set to zero, so your hairs have their width multiplied by zero giving nothing to render. By default this is 0.01 so you have changed it for some reason

1 Like

Oh yes that was it!!! Thank you very much. I must have changed it somehow. Anyways, do you happen to know if particle hair can be exported as .obj and used in another 3D program? I turned my particle hair into mesh, exported it as .obj, the file had around 90+mb and then I imported it into another 3D program but it was invisible.