Cycles Rendered View vs Final Render Problem


I have a weird problem with emission material.

When I use “Rendered” in “3D View” it renders as it should like below:

But when I press “F12” to render, it doesn’t process the lights correctly:

I also get an error in the Blender Console:
CD_MTFACE: 0 != CD_MTEXPOLY: 1 || CD_MCOL: 0 != CD_MLOOPCOLL: 0 mesh_ensure_tessellation_customdata: warning! Tessellation uvs or vcol data got out of sync, had to reset!

Does anyone know what’s wrong?


You have Color Management disabled in the render properties. Strangely enough, in one of the latest builds I can’t find the option with Cycles enabled. Just set the engine to Blender Render, enable Color management in Render properties (under Shading) and switch back to Cycles Render.

I did what you said and it didn’t work. I tried deleting objects (Polygons) and see if it would get fixed. It was the wall that had a weird problem. I recreated it and it worked.