Cycles renders subsurf preview settings instead of render settings


I’ve been having this issue for several months now, but it has become frustrating by now. Simply put, no matter what I set at “render” subdivisions, it will render with the settings in “view” when I hit F12. Same with turning the “display modifier in viewport” off (with the eye icon) - it won’t render properly even if the “use modifier during render” (camera icon) is turned on.
I’m using 2.71 64bit stable on a Windows 8.1 x64 machine and render on a GTX580.

Any input appriciated, cheers!

Hmm. Don’t see such behaviour here. Some forgotten setting under “Simplify”, perhaps?

Or maybe Blender re-using the BVH cache from a previous test render?

Could you prepare a simple scene that shows the problem and upload that for us to e.g. pasteall? Much easier to diagnose!

Thank you for your answer, simplify is unchecked. Here’s the .blend, as you can see, every object has a subsurf modifier preview level set to 0, render set to 3 or 4, still it renders without subsurf on my machine.

The problem is not the render settings, but your geometry. You have some weird meshes within meshes thing going on there, with internal polygons overlapping the outer ones. Quite tricky to clean up, as “Remove Doubles” can not spot them…

Your modifiers are disabled, that is why their names show up RED.

My guess is you have unapplied shape keys.

Here is a related thread.

Here’s a render of your scene after a little geometry cleanup:

On further expection: I think it’s the shrinkwrap that causes the issue. You want the shrinkwrap to wrap around the sides and the cushions.

Problem: Both have a subsurf level of 0 for the view and only get subdivided at rendertime. So Blender would have to follow a certain order of operations: First subdivide base mesh - then subdivide shrinkwrap mesh - and finally wrap shrinkwrap mesh around subdivided base mesh. That’s not going to work implicitly at rendertime.

Give the “base meshes” their final level of subsurf for viewport/editing. Blender should then be able to take care of the rest.

Thanks, that’s right, it’s the shrinkwrap. Although I still don’t get it, why can’t it work independently from view settings.
Yes, as you’ve said I use it to simulate creases on the mesh instead of sculpting, looks great on textured well-lit renders, but generates too much extra geometry, it gets hard to edit, so I thought I’ll lower the viewport resolution, that’s how I came across the problem. Do you think this is normal and intended to work like this?
Edit: Actually your first guess is the solution to my problem. I can leave every resolution setting at maximum, and just turn on simplify. That way meshes stay easily editable. Cheers!