Cycles, simple polygone, smooth shading and normal map = weird shading. But why?

Hello. I have simple detail, and one part of it dispay weird shading.
it is clearly seen on tumbnail

Here is topology


Nothing special - just polygone. I checked for double vertices, direction of normals -all seems normal. All vertices share the same coordinate along Y, so that polygone is completely plain. I try to unplug normal map, but problem still exists. So, why this is happening?

Post the packed blend.

Here it is weird_shading.blend (583 KB)

Your normals change too fast over the sharp edges so the smoothing algorithm creates artifacts. You can:

  1. Add an Edge Split modifier to the bottoms of the tall polygons
  2. Mark same edges as Sharp in the toolbox panel
  3. In the Mesh properties, open the Normals panel and turn on Autosmooth. Lower the angle until the offending faces appear flat.


4. Or rotate the inner edge from the top rigth poly. (select the poly, ctrl+t, ctrl+f, alt+j)

Thank you СD38
Strange, but i never experience something like this before. Even when angles were sharp. I will try to mark edge as sharp.
I also wonder, why shading is weird only at one polygone?
I read at stackexchange that theese methods (Edge Split, Autosmooth) are oudated. And i think they really are, since we have a lot of different angles at model, and tweaking proper angle in settings may be impossible. Dividing model is also not an option, since object must be logically subdivided into separate meshes, like in real life.

Thank you Secrop.

  1. I select polygone and press Ctrl+T -> Polygone divided into two triangles. No wonder, since this command triangulate faces :wink:
  2. Press Ctrl+F -> and recieve menu where i must choose “Rotate edge CW” i guess. It is only appropriate option in my case, as i understand.
  3. Then i press Alt+J -> Ahh! I never knew about this command, that join two triangles in polygone. I always used “F”. What is the difference between them?

I will try render image now.

UPD: Sadly, but it does not work. I guess i must change topology completely. And then start over. Create new UV, rebake maps and so on.

UPD2: Mark Sharp does not work either. And EdgeSplit is also not an option, since i need no coincident vertices.

Alt+J creates a poly by joining the faces, F makes a new poly but keeps the original triangles.

I’ve tested your file, and noticed that just by triangulating the face, blender fixes the edge automatically and there’s no need to rotate it after…

http://www.pasteall.org/blend/42723

Secrop many thanks! You, kind sir, just saved hours of my life! If there is a shiny Blender Gods Pantheon, your statue must be there. Hundred meters tall.

F creates one quad from 2 selected consecutive triangular faces. New face is created if verts or edges are selected; even then, if there are faces already present double faces wont be created. What can go wrong is if F and J keys are not properly used. F connects vertices while J connects + cuts edges in between.
Btw, Auto Smooth is fine in this example. Rarely, if there are a lot of different curved surfaces converting to flat, it fails.
Never knew it’s old fashioned. Turbosmooth and Smoothing groups are better ;)?
http://www.pasteall.org/blend/42738

Thank you, eppo but Secrop method solved the problem entirely. I’m not sure where i read that AutoSmooth is outdated. It seems somewere at stackexchange. I never used Turbosmooth and Smoothing groups, since i’m not 3D Max user. :slight_smile: