Cycles Smoke won't show in rendertab

Hello, I have baked smoke simulation and it was working fine, I have even rendered it. Then I wanted to set up more resolution in simulation and render it again. Since I baked it second time with more res, I can’t see it on render tab. The screen is blinking in render tab and there’s no smoke in the rendered image. I’m using blender 2.91 Beta, Rendering Cycles CUDA (cpu or eevee won’t render too) and it’s not first time I see this. It happend to me before when I forgot to set a material for Smoke Domain. I tried to change some nodes in shader, change resolution, frame stamps and other properties of simulation. Nothing helps.

Solved. I have turned off particle system view which was the source of the smoke. It must be visible when baking simulation. Weird result anyway with the blinking screen.