Cycles strand render movie

A quick test recording rigid body simulation from BGE then rendering in cycles with the new strand renderer. First ball is cloth to test if strands work with cloth. (nope)

why wouldn’t strands work with cloth? it’s just a particle system modifier, which would have to come after the cloth modifier. i’m not currently on my OS that has the patched strand build, so i can’t test right now, but is that somehow non-functional in this build?

Yeh… Seems to work from scratch, but in this case I applied a soft body first, then cloth. It leaves the strands behind. So the strands for this cloth were floating up off screen. So it looks like a bug or not working yet if you click on soft body then cloth on and off.

nah, no bug, just check your modifier stack. particle system needs to come after cloth or soft body. i tried what you said, turning on softbody, then particle system, then turning off softbody and using cloth instead. what happens is that when i delete the softbody modifier, the particle system is now the first and only modifier in the stack - then adding a cloth sim puts the cloth modifier AFTER the particle system. unless you doubled checked this and it STILL leaves the particle system behind, then you might just have to clear your cache, or something else.



Do you know a way how to prevent hair falling through the emittergeometry ?

Kind regards

not really. having a collision modifier on the emitter before the particle system modifier is supposed to work, but it just doesn’t seem to do the trick. i’m not sure it’s even feasible after Blender 2.49b. or your settings have to be just so, and i can’t quite figure out what settings are supposed to work without a hitch.

@ohsnapitsjoel Ah, cool. Thanks!