Cycles transparency noise

So, after a while of not using blender rendering part (I was just modeling for my TF2 workshop) i wanted to do some “art” and i had some problems with Cycles, having noise on the renders.

Here are some images:







On the first one it’s very dark, i believe it was because of the model being too close to the plane, since on the other two it isn’t dark. However, it still has noise on both last images.

I tried changing some settings, but since i don’t even know what settings i have to change, i searched the web and found nothing about the transparency and all this things, so i thought asking here was a good idea.

Thanks in advance :smiley:

E: After some testing and research, i found that using HDR ilumination (Not sure if it’s called that way) can solve the noise problem, but then they feel too cartoony
http://gyazo.com/7ba3890672caeb9d9d29fbb2c84dd322

So i still need to solve the noise using emmiters as light, since it looks just like i wanted it to look, but with noise.