Cycles transparency not entirely transparent?

Hello Blender artists,

I am trying go create an entirely transparent material in cycles (so I can animate an objects visibility), but even when I use the Transparent BSDF and set its color to white I still can see some of the geometry.

Here’s a screenshot of how it looks:

That’s a Suzanne that should be invisible, but is still visible.
Does anybody know why it doesn’t work?

Blend file is also attached if anyone wants to have a look.




Transparency.blend (590 KB)

Basic transparency in Cycles using a special depth setting that determines the amount of transparent faces a ray will go through before it is terminated, try increasing the number of transparent bounces (in the integrator panel)

Set the integrator to full global illumination and that should fix it. Default settings is not enough transparency bounces. Also, there is a couple of duplicate verts in Suzanne that may or may not be causing some of the issue.

Ah, perfect. Works now.
Thanks for your quick help, Ace Dragon!