[Cycles] Transparent textures causing issues

Okay first things first, i’m not looking to use the transparent parts of the textures as transparency.
I’m working with assets ripped from a game where they cram as much into the 4 main channels as they can.
For example, 2 channel normal map in R and G(z is generated), AO in B and a detail tiling mask in the alpha.
However, the alpha is causing issues in the final render as the transparent parts of the image are being treated as black, leading to bad normal map distortion.
Is there any way to fix this without making a copy of the texture just for the alpha?(trying to minimise blend file sizes.)

You need to set the alpha mode to the new “channel packed” mode recently added to 2.80:

Straight alpha mode, despite it’s description and name, still premultiplies the color channels by alpha, etc.

The modes weren’t doing anything in Cycles for me.
Just checked the blender git and it seems like it was bugged.
Will try update blender and see if it helps.

Almost always alpha used for transparency showing black means you need to increase your max bounces and transparent bounces.

Still broken.
The alpha settings make no difference to the render.

Is the texture you are using packed in the blend file? Because that combination on “channel packed” is still premultiplied.

Yeah unpacking the textures fixed it.
Thank you!

This should be fixed in the current build now. My years of duplicating textures are finally over.